Have to manually type startx in TTY during boot

I never had this problem but when now I when was trying to install DWM, and there was a command to type startx in the terminal. It rebooted my PC to Manjaro but a black screen with a cursor on it. After a few minutes of digging with TTY (CTRL+ALT+F2), I could easily then start it with startx. However, I thought this fixed that black screen issue, so I rebooted it again just for me to see the issue again.
Now I have to manually boot Manjaro via this way.

However, it should also be noted that during the boot process, there were no error messages.

I have tried looking through other posts, but all returned no luck:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu

My build:
Kernel Version → 5.13.15-1-MANJARO
KDE Plasma Version → 5.22.5
Processor → AMD 4700U
GPU → Renoir
Dual-booting → Windows10 & ManjaroKDE

Any potential fixes?

Thanks, if there is further information needed, I will provide them with the best of my capabilities

Edit 3:
After a few restarts and retries now when typing startx there would be a great delay followed by a line saying something in the following:
xauth:timeout in locking authority file /home/jackm/.xauthority but after this there would be some more text but I was unable to take note, however the system shortly booted into Manjaro. Issue still remains.

See from TTY if you have multiple files that prevent you from logging in
ls -l .Xauthority*

If you see 2 or more, then run:
rm -fr .Xauthority-*

If that doesn’t work, you might want to fix your home permissions like this:
chmod u+rwX $HOME

Thanks for the reply.
For the output of ls -l .Xauthority* is the following in TTY:
-rw------- 1 root root 50 Sep 17 21:26 .Xauthority
-rw------- 2 jackm jackm 0 Sep 18 08:19 .Xauthority-c
-rw------- 2 jackm jackm 0 Sep 18 08:19 .Xauthority-l

Then I proceeded with the second command, no errors given, then I ran the third command of fixing home permissions.

Then I did a reboot, but the issue still persisted.

However, another edit note is that after typing startx I have to also tap-press CTRL+C for a few seconds and then it will boot regularly.