Have Not Received Any Package Updates

I haven’t received any recent updates from Manjaro ARM stable releases. When I run sudo pacman -Syyu, it finds no new updates. I think it has been a few months sine the last update, but I not sure how to check the date of the last update.

I am wondering if I have the correct mirrors for Manjaro ARM or maybe it is some other issue.

Any help would be appreciated.

System: Host: pi4 Kernel: 4.19.108-1-MANJARO-ARM aarch64 bits: 64 Desktop: KDE Plasma 5.18.3 Distro: Manjaro ARM
Machine: Type: ARM Device System: Raspberry Pi 4 Model B Rev 1.1 details: BCM2835 rev: c03111 serial: 1000000005d08cb7
CPU: Topology: Quad Core model: N/A variant: cortex-a72 bits: 64 type: MCP
Speed: 600 MHz min/max: 600/1500 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 4: 600
Graphics: Device-1: bcm2835-vc4 driver: vc4_drm v: N/A
Device-2: bcm2835-hdmi driver: N/A
Display: x11 server: X.org 1.20.7 driver: modesetting resolution:
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: bcm2835-audio driver: bcm2835_audio
Device-2: bcm2835-hdmi driver: N/A
Sound Server: ALSA v: k4.19.108-1-MANJARO-ARM
Network: Message: No ARM data found for this feature.
IF-ID-1: eth0 state: down mac: dc:a6:32:20:6f:12
IF-ID-2: wlan0 state: up mac: dc:a6:32:20:6f:13
Drives: Local Storage: total: 59.48 GiB used: 12.98 GiB (21.8%)
ID-1: /dev/mmcblk0 model: SC64G size: 59.48 GiB
Partition: ID-1: / size: 58.40 GiB used: 12.94 GiB (22.2%) fs: ext4 dev: /dev/mmcblk0p2
ID-2: /boot size: 93.8 MiB used: 38.5 MiB (41.0%) fs: vfat dev: /dev/mmcblk0p1
Sensors: Message: No sensors data was found. Is sensors configured?
Info: Processes: 178 Uptime: 34m Memory: 3.73 GiB used: 1.68 GiB (45.0%) Shell: bash inxi: 3.0.37

First try to sort/refresh your mirrors:

sudo pacman-mirrors -f && sudo pacman -Syyu

@cscs When running sudo pacman-mirrors -f I get the following error:

pacman-mirrors: error: unrecognized arguments: -f

I am guessing I don’t have the right version of the package, but perhaps it is some other issue. I am not sure how to upgrade/install the package.

When running pacman-mirrors --version I get the following:
pacman-mirrors 2.0

What is your current kernel version. I believe you are using the old mirriors.

[ray@pi4 ~]$ sudo pacman-mirrors --version
Version 4.16.5

@Darksky In the system info it appears to be Kernel: 4.19.108-1-MANJARO-ARM aarch64. Is that what you are talking about?

Yes. It appears you are on the wrong mirrors. The current kernel is 5.4.79.

Try the directions here to change your mirrors in post #1.


1 Like

@Darksky So after upgrading all the packages and restarting I ran into the following issue:

ERROR: device LABEL=ROOT_MNJRO not found. Skipping fsck.
:: mounting LABEL=ROOT_MNJRO on real root
mount: /new_root: can’t find LABEL=ROOT_MNJRO.
You are now being dropped into an emergency she’ll.
sh: can’t access tty; job control turned off
[rootfs ]#

I saw that there was some documentation about changing the label in a couple of files. However, I have not been able to get the shell to recognize any USB keyboard presses.

Any help would be appreciated.

You will have to put the sdcard in another computer to make changes in the boot partition since the root partition is not getting mounted so the modules can not load.

A quick fix is to copy the cmdline.txt.pacsave to cmdline.txt or edit cmdline.txt and change root=what-ever-it-is to root=LABEL=ROOT. This will have to be done after every kernel upgrade before rebooting.

The best thing to do is change to root partition LABEL to ROOT_MNJRO and never have to mess with again.

@Darksky just for clarity. Is the LABEL the same thing as the partition name? I did change the name from BOOT to ROOT_MNJRO. I didn’t have a cmdline.txt.pacsave file but I did have a cmdline.txt. In that file it already had the value of root=LABEL=ROOT_MNJRO.

I get a different error on boot now:

ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck.

You want to change the name in cmdline.txt to match the name on your root partition which if I remember right it is ROOT. You are telling the pi where the root partition is so it can boot into it. So:


Only you know what you did there but there 2 partitions (boot and root) You need to straighten that out.

I did have a typo above and fixed it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.