Hashcat with Nvidia

Hello everyone. I finally got a GPU worth trying some hashcat.

sudo inxi -Fxxxmz
[sudo] password for arkansawdave: 
System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GP62 6QE v: REV:1.0 serial: <filter> Chassis: type: 10 serial: N/A 
           Mobo: Micro-Star model: MS-16J5 v: REV:0.A serial: <filter> UEFI: American Megatrends v: E16J5IMS.11D 
           date: 01/19/2018 
Battery:   ID-1: BAT1 charge: 39.0 Wh condition: 39.9/43.2 Wh (92%) volts: 12.2/10.8 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Unknown 
Memory:    RAM: total: 7.54 GiB used: 1.75 GiB (23.2%) 
           Array-1: capacity: 32 GiB slots: 2 EC: None max module size: 16 GiB note: est. 
           Device-1: ChannelA-DIMM0 size: 8 GiB speed: 2133 MT/s type: DDR4 detail: synchronous bus width: 64 bits 
           total: 64 bits manufacturer: Samsung part-no: M471A1K43BB0-CPB serial: <filter> 
           Device-2: ChannelB-DIMM0 size: No Module Installed 
CPU:       Info: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S rev: 3 L1 cache: 256 KiB 
           L2 cache: 6 MiB L3 cache: 5.9 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41621 
           Speed: 900 MHz min/max: 800/3500 MHz volts: 1.1 V ext-clock: 100 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 879 
           5: 900 6: 900 7: 900 8: 898 
Graphics:  Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
           Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: Micro-Star MSI driver: nvidia v: 455.45.01 bus ID: 01:00.0 
           chip ID: 10de:139a 
           Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus ID: 1-11:4 chip ID: 5986:0683 serial: <filter> 
           Display: server: X.Org 1.20.10 driver: modesetting,nvidia resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: GeForce GTX 950M/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 chip ID: 8086:3165 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:e0a1 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 960.42 GiB used: 207.48 GiB (21.6%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: A3U0 
           ID-2: /dev/sdb type: USB model: General USB Flash Disk size: 28.91 GiB serial: <filter> rev: 1100 
Partition: ID-1: / size: 31.25 GiB used: 19.35 GiB (61.9%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 98.4 MiB used: 298 KiB (0.3%) fs: vfat dev: /dev/sda1 
           ID-3: /home size: 622.47 GiB used: 188.13 GiB (30.2%) fs: ext4 dev: /dev/sda4 
Swap:      ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 45.0 C mobo: 27.8 C gpu: nvidia temp: 40 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 272 Uptime: 27m wakeups: 1 Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1249 
           Shell: Bash (sudo) v: 5.1.0 running in: terminator inxi: 3.2.01

I’ve got cuda and the opencl pkg. Also have optimus-manager and optimus-manager-qt for switching gpus. I’m getting a warning about some kernel time out and I’ve followed the instructions in the link exactly to fix it, but still get the warning. Here is that link to the instructions I used. I used the newer instructions. I tried the older instructions when it still showed the Warning, but that resulted in failure to boot. Had to fix with an installer usb.


[arkansawdave@missi .work]$ hashcat --hash-type 0 --opencl-device-type 2 test.hccapx rockyou.txt
hashcat (v6.1.1) starting...

* Device #1: WARNING! Kernel exec timeout is not disabled.
             This may cause "CL_OUT_OF_RESOURCES" or related errors.
             To disable the timeout, see: https://hashcat.net/q/timeoutpatch
* Device #2: WARNING! Kernel exec timeout is not disabled.
             This may cause "CL_OUT_OF_RESOURCES" or related errors.
             To disable the timeout, see: https://hashcat.net/q/timeoutpatch
nvmlDeviceGetFanSpeed(): Not Supported

* Device #1: GeForce GTX 950M, 1772/2004 MB, 5MCU

OpenCL API (OpenCL 1.2 CUDA 11.1.114) - Platform #1 [NVIDIA Corporation]
* Device #2: GeForce GTX 950M, skipped

Minimum password length supported by kernel: 0
Maximum password length supported by kernel: 256

Hash 'test.hccapx': Token length exception
No hashes loaded.

Started: Sat Jan 16 05:46:22 2021
Stopped: Sat Jan 16 05:46:22 2021

I’m not sure why, but it stops after just a second. Is it because of the mentioned kernel timeout? Or is it because I haven’t figured out the hashcat command completely, and could anyone give me a hand with it? TIA for any help or insight.

Says Token length exception for my test file too, which is a complete 4 way handshake .cap from airodump-ng converted with the converter included in hashcat-utils. The same .cap file runs fine in aircrack-ng and fast too with this quad i7. 30 minutes for rockyou.txt…wow.My previous best CPU was a dual core i5. This is nearly twice as fast.

Might be your command. Best bet is to grab a video off of YouTube which has an accompanied hash and follow that. The reason being there is so many different types of hashes and if you enter the wrong hash type you’ll be thrown an error and it won’t run.

1 Like

Seems like your file is either corrupted or not the in appropriate format?

Have you tried something like hashcat -d 1 -b to see if it works?

1 Like

Yeah. I almost wished it were errors so it would let me know something more, but there’s no error. It looked to me like it was completing. After watching a couple of youtube videos, even their completions with results barely showed more than that, and they ran in approximately the same amount of time. I made sure to make that .cap with a passkey NOT in the rockyou.txt so that I could see just how much faster it is with my GPU than my CPU to run through the whole list. Is it possible that it’s running through the whole dictionary in 2 seconds? It’s my first time with hashcut, so I don’t know what to expect, but that’ll blow my mind if it’s really that fast. No way…but I’ll have find someone to connect to my hotspot and catch another with a passkey I know is in there and run it again to find out…

Is hashcat that fast? Do I just not realize yet? That dictionary has like 15,000,000 keys and takes 30 minutes with aircrack-ng.

Got this figured out. Should have been hash type 2500.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.