Has anybody ever succeded in launching the program "Sonic Pi"?


#1

Hi folks !
All is in the title. For a couple years now, I have never been able to launch Sonic pi, “The live coding music synth for everyone”.
It used to be a program available from AUR and I’ve had trouble installing it.
Now, it is available from the community repos (v3.1.0-3), and I’ve installed it, yet… it doesn’t work! I wanted to know whether someone ever got it to work on their computer. Any luck ?

On my pc, it just gets stuck at launch, even when I sudo it.

I am using Manjaro Cinnamon, kernel 4.19.4-1, if that information helps.


#2

what is the ouput when you attempt to launch it from the terminal ?

…nvm … I checked and it doesnt run here too, with no output.


#3

i got it to work more or less nicely a year ago. the sonic pi guy isn’t particularly keen on patching stuff for distros that aren’t raspbian or whatever ubuntu version this works on.

if you’re keen on livecoding though, there’s a whole bunch of other stuff you could try that works just fine


#4

The git version doesn’t build because it needs a package (qwt-qt5-opengl) which is neither in the repos nor in AUR.
I guess that it has been superseded by another qwt package, which means that the PKGBUILD needs some rework.
Also, one of the patches doesn’t apply.


#5

Thank you all for your kind answers!
Deadguy, do you know of a program similar to sonic pi? I really love the idea of coding music. What would you recommend?


#6

there’s a number of alternatives for you to try. some more complex than others, but i’ll let you be the judge of that.
most notable are tidalcycles and foxdot. you can (and should) also check toplap for all things livecode


#7

I have installed and tried to launch it, it is stuck at launch, later found some log in ~/.sonic-pi

[GUI] - waiting for Sonic Pi Server to boot...
............................................................
[GUI] - Critical error! Could not boot Sonic Pi Server.

[GUI] - Sonic Pi Server failed to start with this error message: 
      > Server Exception:
 SIGTERM
 ["/usr/share/sonic-pi/server/lib/sonicpi/util.rb:549:in `wait'", "/usr/share/sonic-pi/server/lib/sonicpi/util.rb:549:in `kill_and_deregister_process'", "/usr/share/sonic-pi/server/lib/sonicpi/scsynthexternal.rb:224:in `rescue in boot_and_wait'", "/usr/share/sonic-pi/server/lib/sonicpi/scsynthexternal.rb:221:in `boot_and_wait'", "/usr/share/sonic-pi/server/lib/sonicpi/scsynthexternal.rb:417:in `boot_server_linux'", "/usr/share/sonic-pi/server/lib/sonicpi/scsynthexternal.rb:151:in `boot'", "/usr/share/sonic-pi/server/lib/sonicpi/scsynthexternal.rb:37:in `initialize'", "/usr/share/sonic-pi/server/lib/sonicpi/server.rb:78:in `new'", "/usr/share/sonic-pi/server/lib/sonicpi/server.rb:78:in `initialize'", "/usr/share/sonic-pi/server/lib/sonicpi/studio.rb:183:in `new'", "/usr/share/sonic-pi/server/lib/sonicpi/studio.rb:183:in `init_scsynth'", "/usr/share/sonic-pi/server/lib/sonicpi/studio.rb:56:in `initialize'", "/usr/share/sonic-pi/server/lib/sonicpi/lang/sound.rb:125:in `new'", "/usr/share/sonic-pi/server/lib/sonicpi/lang/sound.rb:125:in `block (2 levels) in included'", "/usr/bin/../../usr/share/sonic-pi/server/bin/sonic-pi-server.rb:177:in `new'", "/usr/bin/../../usr/share/sonic-pi/server/bin/sonic-pi-server.rb:177:in `<main>'"]
[GUI] - UDP OSC Server no longer listening

and

connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)

JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
Please check your /etc/security/limits.conf for the following line
and correct/add it if necessary:

  @audio          -       rtprio          99

After applying these changes, please re-login in order for them to take effect.

You don't appear to have a sane system configuration. It is very likely that you
encounter xruns. Please apply all the above mentioned changes and start jack again!
/usr/share/sonic-pi/server/vendor/sys-proctable-1.1.3/lib/linux/sys/proctable.rb:112: warning: constant ::Fixnum is deprecated
/usr/share/sonic-pi/server/vendor/sys-proctable-1.1.3/lib/linux/sys/proctable.rb:112: warning: constant ::Fixnum is deprecated
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
terminate called without an active exception
/usr/share/sonic-pi/server/vendor/sys-proctable-1.1.3/lib/linux/sys/proctable.rb:112: warning: constant ::Fixnum is deprecated

#8

Hey - good on you for looking deeper than I did.

Did you by chance try after adding that line to /etc/security/limits.conf ?


#9

Nope, I only tried to run the program once and nothing else


#10

Aw c’mon … I thought you were going to see how deep the rabbit-hole goes :smile:


#11

Not this time :upside_down_face:


#12

Hey ! Thanks for looking into it guys! I’m glad to see that the program has a problem and I’m not the one being crazy.

Thank you deadguy for your suggestions ! FoxDot is terribly attractive, as I love python and its intended beginner-friendliness/readability. I was able to pip-install it, but making it work seems a bit too technical for me. I’ll look into it.


#13

you’ll probably need tk/tkinter on the python side. and supercollider and jack on the audio side


#14

Indeed, and I installed it, yet I get an error message when starting FoxDot in supercollider :

-> FoxDot
Booting server 'localhost' on address 127.0.0.1:57110.
Found 10 LADSPA plugins
jackd 0.125.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

could not initialize audio.
Server 'localhost' exited with exit code 0.

I can still launch FoxDot from terminal, but I get no sound. I’m soooo close and that is sooo frustrating!


#15

you need jack2. also you have to start jack first, then supercollider, then the foxdot GUI


#16

Thank you deadguy!
I have installed jack2, but I have no idea how to start it, honestly. I have tried installing Qtjack and starting it from GUI, but it doesn’t work. I’m doing something wrong. Typing “jack2” into the terminal doesn’t work either (“command not found”).


#17

you should also get all the relevant pulseaudio plugins (mainly pulseaudio-jack, and pulseaudio-alsa i think). after that, your best bet is to get cadence.
i believe you can find info on how to use it around the forums. otherwise a quick search ought to do it.
the best known config is to set the bridge type to “alsa -> pulseaudio -> jack (plugin)”


#18

I’ll look into it ! Thank you deadguy, your feedback and insight are precious.