Hardware clock is changing randomly

depending on the motherboard manufacturer, all you may actually need is a USB thumb drive formatted to FAT32 to save the ROM update to and be read from as some implement a method of flashing updates directly from USB thumb drives from the motherboard’s ROM. Both ASUS and MSI do this and my old ASUS P8-H61M LE/USB3 board from back around then certainly had the feature.

the CR2032 type CMOS battery would certainly be worth changing now regardless, if you can acces it as they don’t last forever. just be careful when doing so not to damage the contacts. also make a note of all firmware settings not set to auto beforehand and have a clock handy to reset the correct time afterwards as you need to swap batteries with mains power off and any removable external battery disconnected as well to avoid shorting the laptop’s motherboard.

3 Likes

The ntp package contains /usr/bin/ntpd, no need to install anything else. Right from the wiki page you linked:

Install the ntp package. By default, ntpd works in client mode without further configuration.

networkmanager-dispatcher-ntpd is just a dispatcher script.

I checked for bios update in windows but there is no update.
I think it is issue with some package in linux.
And the battery is good because windows dose not have this issue.
systemd? Just a thought.

You have windows.
Change windows timesetting to utc.
See here or many other places in this forum.

1 Like

Reliable timesync is done using the systemd-timesyncd service.

Check if the time syncronization service is running.

systemctl status systemd-timesyncd

Eventually enable it

sudo systemctl enable --now systemd-timesyncd

Before syncing, time will display different times.
Always have hw clock set to one standard, and the best standard is utc.

2 Likes

No, i don’t. Just use another drive.

@linux-aarhus here is the output of first command. So is it enabled? Although i used the second command anyway.

● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; >
   Active: inactive (dead) since Thu 2019-03-14 13:02:59 CST; 3h 16min ago
     Docs: man:systemd-timesyncd.service(8)
  Process: 514 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, statu>
 Main PID: 514 (code=exited, status=0/SUCCESS)
   Status: "Shutting down..."

Mar 14 13:02:39 shaber-pc systemd[1]: Starting Network Time Synchronization...
Mar 14 13:02:40 shaber-pc systemd-timesyncd[514]: The system is configured to r>
Mar 14 13:02:40 shaber-pc systemd[1]: Started Network Time Synchronization.
Mar 14 13:02:59 shaber-pc systemd[1]: Stopping Network Time Synchronization...
Mar 14 13:02:59 shaber-pc systemd[1]: systemd-timesyncd.service: Succeeded.
Mar 14 13:02:59 shaber-pc systemd[1]: Stopped Network Time Synchronization.
lines 1-14/14 (END)

@gohlip My BIOS dose not have utc thing

Indeed - usually UTC - and let system handle timezone.

And that is were Windows is annoying but OP was aware of that.

@saber
You have timesync enabled and unless you have chosen otherwise your hardware will be set to UTC. But booting into Windows might offset your time and then everything starts to go haywire because booting back into Linux the system will expect the clock to be UTC and adjust accordingly.

Just set your hardware clock to UTC (London time)

E.g. I am in Denmark so my timezone is Europe/Copenhagen which is UTC+1. So my system time is 1 hour apart from the hardware time.

1 Like

Whether you use different drives for each OS is immaterial. The system hard ware clock is the same.
Windows OS set hardware clock to local time. Linux OS’s set hardware clock to utc. Yes, you can set linux OS hardware clock to local time and it is easier to do that than to set windows clock to utc. But it is not the right way. Not only daylight saving time may go awry, there are other things we won’t go into. Too technical (time wise) for me.

And correct, we should always sync time but I repeat the hardware clock must be consistent throughout all OS’s.

Oh… windows after some (not all) updates will revert back to using ‘local time’. You need to set it back if that happens.

3 Likes

You’re all wrong (especially @gohlip) the only solution that is entirely recommended is to uninstall Windows. :smile:

As always, it goes without saying that Windows is the root of all evil :smiling_imp:

2 Likes

I don’t have windows in duel boot.
I have two hdd one have Manjaro and other one in windows.
I just replace the drive when in need windows.

I was only kidding around.

That is an excellent approach. Still your clock issue will persist.

I think - without any evidence, to the contrary - the registry change to instruct Windows to use UTC instead of local time will be the approach which creates less issues with the clock changing randomly.

This is nothing to do with windows. i just put the windows drive to check for bios update, someone here asked me that’s why.
And i did not saw any utc time settings in my bios.
also every time i updated the kernel.

Unfortunately, it does.

You won’t. Think of the bios clock (aka Real Time Clock (RTC)) as nothing more than this, and the OS (doesn’t matter which one) can access these knobs to set the time. Once it is set, the CMOS battery keeps the time (whichever way (UTC/localtime) it is set to).

This really doesn’t matter, because without the registry hack for the RTC, due to the fact that when you boot windows, it dutifully sets the RTC to whatever local time you have configured for windows.

Finally, random clock changes (once you settle on a single standard) is indicative of a dying CMOS battery.

1 Like

This should have been asked days ago…

In what way?

I did a clear setup of Manjaro then i saw the time issue again then i reported here and someone told me to check for BIOS Update so i installed the windows in a sperate drive.
So the issue is i did not have Windows 10 when i faced the time issue and not related to windows in my case.

@jonathon
Ha Ha.
It is changing to some hours from my wall clock.
and Am to Pm.
i think that clear this question.

1 Like

somewhere there is a conflict between your bios-os-hdd

i had a similar experience, after i had installed an OS (Haiku) on an old laptop`s hdd (10 years) and password protected the bios, later i removed the password and reset the bios to default, after that my OS time was 5 minutes ahead. i tried changing the time settings, to sync at boot, but still time was not synced.

then i tried booting a Manjaro(32) XFCE live usb… and i got this message:

out of range pointer 0x400
Aborted. Press any key to exit.

and the same message appeared every time i tried to boot a live usb, this happened with 3 different usb sticks, with different software on them (clonezilla,manjaro,acronis)

a google search showed that the message is a linux related sync error, which happens in arch… but was not very clear to me as to why it happens and did not offer a straightforward solution.

after awhile i formatted/wiped the hdd using my live usb installer (Haiku), but still i could no longer boot any other live usb, and i was still getting that message… out of range pointer

my solution was to format the hdd using an old windows install cd. after that i could boot any live usb, and time was displayed correctly. never had any time problems after that.

hope this helps everybody get a better picture of whats going on.
:mantelpiece_clock:

1 Like

Not really…

If the “minutes” is correct but the “hours” is not then it would most likely be that you’ve set up the wrong timezone.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark