Hardware acceleration with AMD does not work in FireFox

I tried web benchmarking on Firefox, but the CPU usage was over 90%. Compared to Chrome, the CPU usage less than 10%.
I notice clearly that FireFox hardware acceleration doesn't work with AMD GPU driver. Chrome and Steam work fine with default driver in Manjaro, but FireFox does not, despite hardware acceleration being active.

KDE Plasma Version: 5.18.4
Kernel Version: 5.6.3-2-MANJARO
GPU AMD Radeon RX5700
AMD Driver: "video-linux" as default driver

in firefox, check about:support
If it says "Basic" under Compositing, go to about:config and change layers.acceleration.force-enabled to true and restart firefox.

1 Like

That's odd, because hardware acceleration does not work in Chromium-based browsers on Linux without the Vaapi patches. You would need chromium-vaapi installed from the AUR.

Thanks for your help.
I configured it, but FireFox hardware acceleration does not work with WebGL Benchmark.
https://web.basemark.com/

you asked for hardware acceleration - WebGL is something different:
webgl.force-enabled - change that one to true

It did not work again. Only CPU works for FireFox alone, not GPU.
Does it work for you?

Hardware acceleartion on Firefox is not working with the new version of libdrm. This has been reported on bugzilla.mozilla.org and bugs.archlinux.org.

1 Like

Oha,
I didn't know that FireFox was using Libdrm.

FireFox hardware acceleartion works now after the update.

Firefox hardware video acceleration works (since v.75) only under Wayland, doesn't it?

Forum kindly sponsored by