Hard lock up before booting - Manjaro x64 XFCE - Samsung Laptop NT301V5A

xfce

#3

Try the latest 4.14 LTS kernel


#4

Thanks for the reply.
I am in Korea by the way ^-^

I also suspect the hardware. But the error message is on the screen and I want to use that to diagnose the fault accurately if possible.
97% doesn’t seem good to me because I have never had this kind of critical failure before except a few years ago with a machine that turned out to have a bad stick of RAM.
I’m used to 100% with Linux. I guess I’m spoiled.
I’ve booted Crunchbang++ maybe 20% more than Manjaro on this machine.


#5

Thanks for the reply.
I think that is the kernel I downgraded from as it was giving me problems and I had to start X manually.
I will install this kernel, try again and report back.


#6

You can keep 2-3 kernels or more and switch between them at boot from Grub Boot Menu. Make some tests and see what kernel suits your hardware better.


#7

Without any logs that show something related to this error with comparison to non-error logs, you can never know if the error is fixed or you are just lucky this time and it’s coming back.
My suggestion is, wait until it happens and (after hard reboot) check journalctl. Preferably save that log for further investigation.

journalctl -b -1

#8

Thanks for the reply.
I have booted several times since the error.
If I check journalctl now will I get the relevant info?
Or do I only get one chance and have to check it immediately after the error on the very next reboot?


#9

If you remember about when it happened and if the logs are not overwritten, yes.
The -b -1 flag asks for the previous boot logs. For available logs list-boots IIRC. Check journalctl --help.


#10

Thanks for the advice.
Here is the journalctl log for the failed boot
I put them on Hastebin.
Too many chars for the forum.

Failed boot
https://hastebin.com/refowiregu.vbs

Regular boot
https://hastebin.com/ukoroburub.coffeescript

I have no idea how to examine these logs or what I should look for.


#11

I am no expert either.
So far, where the logs stop, the last thing was

systemd[1]: Starting udev Kernel Device Manager...

which never started.

  • Did you try other kernels as advised? What problems did you have that made you use this kernel?
  • Crunchbang uses kernel 4.9. Did you ever try that in Manjaro?
  • Did you have some USB device, or other devices connected during your failed boots?

I would suggest to try other kernels and maybe troubleshoot them instead.


#12

This is the reason why I downgraded the kernel. X would not start as normal. Would just get a black screen with a flashing cursor.
Had to ctrl F2 (alt?) and start x manually by typing in a terminal ‘startx’.


#13

Not yet, been busy.

I’m not sure - will check and report back.

No. No USB devices connected - no devices connected at all.


#14

This has little or nothing to do with the kernel. GPU drivers, LightDM mostly suspects.


#15

Hi, did you run memtest?


#16

Downgrading the kernel fixed the issues on both Manjaro and Crunchbang installs, so it surely must have had something to do with the kernel.
That issue was on every boot and was fixed immediately once the kernel was downgraded.


#17

Thanks for the reply - no I did not.
Will run today.


#18

To which version did you downgrade?

I thought it was only Manjaro and only rare.

I may have misunderstood…

or

Is it not early to say it is solved? How many times did you reboot?
I wish you luck!! :raised_hand_with_fingers_splayed:
Anyway, mark some post as the solution then.


#19

Both are shown in the inxi output on the first post.

Sorry, you have misunderstood.

This was an error I had previously (not a hard lock up) and I fixed it by downgrading both Manjaro and Crunchbang to an older kernel (which you can see listed in the inxi output in the first post).

Thanks for taking the time to reply and trying to help.
It isn’t resolved - but I’m sure we can get there in the end.


#20

Memtest ran for 11 hours today.
Zero errors.

Edit:
Was going to upgrade kernel to the latest again and see what happens.
I have just rebooted for the first time after memtest and what do you know - it hard locked again.

I’d better grab a pic and get the logs.

Failed boot #2
https://hastebin.com/idetugenuk.vbs


#21

Just did this.
Got the weird bug that I encountered before (maybe I misremembered and I didn’t have to start X manually) where on every boot the screen stays blank until I hit a key or move the touchpad. Weird bug and I can live with it - but it is kind of annoying.

This bug does not happen on
Kernel: 4.4.131-1-MANJARO

I will leave 4.14 LTS kernel installed and as default for now, and live with the weird bug about having to hit a key or the touchpad to load up the desktop.
Let’s see if the hard lock up occurs under 4.14 LTS.

Edit:
You can see a video (74mb) of the weird login display bug that occurs on 4.14 LTS.
Note the Conky displayed uptime at the end of the video.


or

Edit:
Just realised that if I leave it alone and don’t touch the touchpad or keyboard it does eventually display the desktop on its own after about 40-50 seconds.

Edit:
I think that is related to

Edit:
Installed haveged and delay on startup solved.
Will now continue to use 4.14 LTS kernel and see if I encounter a hard lock up on this kernel.


#22

Since upgrading to the latest lts kernel and applying all upgrades as they have been coming out…so far so good.
No crashes.
Will keep this updated if aything changes.