Hard Drive unacessable again after booting into Win10 [Windows-Manjaro Dual Boot]

I have a HP laptop with a win10 + Manjaro KDE plasma dual boot installed on my SSD, I don’t use windows much and opened it yesterday and now my HHD that I use to store my data is inaccessible. I have tried copying and pasting data as well as creating a new file and saving it on the drive but it appears that I have read only permissions.
My fstab entry was this

#data drive automount (dev/sda1)
UUID=C028D53E28D5345E   /run/media/myname/DATA ntfs-3g defaults        0       0

I believe it is not tampered and isn’t the root of the issue.

Also I have tried the sudo chmod -R 777 /pathtodrive command in terminal but it didn’t have any effect.
Is it possible that Win10 overwrote the permissions of the drive, how do I grant them back to myself or the system permanently ? ( so that this never happens again )

Two most common possibilities:

  1. A hibernation file was created on the drive
  2. The NTFS file-system was marked dirty

Either of the above two scenarios will fallback to “read-only” when you mount it in Linux; regardless of permissions, regardless of options, regardless of forcefully invoking ntfs-3g.

You can either disable hibernation in Windows and/or run a disk check within Windows. (Or preferably both!)

Then reboot into Manjaro and see if it is resolved.


Another option is to try fixing it within Manjaro. (Don’t rely on this method unless the previous options in Windows did not work.)

sudo ntfsfix /dev/sda1

If it doesn’t work, you can then try:

sudo ntfsfix -d /dev/sda1

Using -d is not usually necessary. Only try it if the first ntfsfix did not work.

Make sure the device names are correct!


UPDATE: Don’t run these commands on a mounted file-system. Be sure that /dev/sda1 is not mounted if you try to fix it under Manjaro.


UPDATE 2: The heck is 334ed74d035d4b17a2f3. Is it your… DNA’s UUID? :open_mouth:

2 Likes

To add on what has already been said, disable Fast Startup in Windows as well as Hibernation, in the advanced Power Settings like explained here [Windows 10] How to disable Fast Startup in Windows | Official Support | ASUS Global (it’s a FAQ about ASUS laptops but whatever it is information with images).

On my side I wouldn’t mess with a Windows 10 partition from Linux, I would use Windows to work with the partition. Anyway probably the first steps would be enough.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.