Hard Drive set as read only

As stated above, my internal hard drive (connected through sata) is being marked as read only. The drive is formatted in ntfs in order to be read/written on my Windows dual boot.

I was able to find a partial fix to the problem through the internet with this command
“sudo mount -o remount,uid=1000,gid=1000,rw /dev/sda2”
However, upon every reboot it goes back to being read only. Is it possible to find a permanent fix to my problem? Any answer would be much appreciated.

Yes, set the options in /etc/fstab (with an editor) :wink:

As you dual boot windows maybe the cause of the issue. You should disable fast startup in windows.

Control Panel>Power options


You can run:
sudo chmod a+rwx mountpoint-of-your-partition
for read-write permission.

This is the output when you run pwd opening a terminal from your drive or partition and should be something like /run/media/$USER/xyzabc

This is a quite common question - which has been asked and answered numerous times.

Reboot into Windows → disable Windows Fast Startup and hybrid sleep/hibernation → run chkdsk c: /F → reboot into Manjaro

Linux ntfs driver have found the filesystem to be in a dirty state - this happens when you don’t do a clean shutdown from Windows.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.