Hangs when (tries) waking from sleep - possibly related to mouse?

If modprobe didn’t rise up the mouse from the dead made the mouse work again, please let me know and follow @megavolt 's suggestion…


i have tried both and don’t see any differences.

I might as well say that for trying all this experiments i have set go to sleep in 1 minute and i wait roughly 1 minute and then i touch the touchpad, and it always wakes up. The touchpad is disabled in settings. Then i notice a pattern: it always hangs roughly after a minute of waking up.
I think it only hangs in sleep if it stays in sleep too long, but i don’t have the time to test that continuosly.

I can disable sleep mode (i don really need it), i just hope this is fixed in kernel or somewhere.
Also i am going to buy a new mouse friday or something then i test again to know if it was a mouse incompatibility with touchpad (i don’t believe since both are HP).

1 Like

i just discovered this problem has not only to do with the sleep mode, because i deactivated it and today i let the screen dim, and after “wake up” the mouse was blocked (both touchpad & wireless), only keyboard active.

I’m all out of ideas then, except:


1 Like

Fabby thank you very much for your support.
The problem with hanging after wake up seems gone after this last update.
I have tested 4 times (2 times waiting 1 minute, 2 times waiting around 30 minutes in sleep). Both playing around a little after to see if it hangs.
However it still wakes up only with touchpad.
On a side note this update also solved No irq handler for vector / Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0 for me. :slight_smile:

I have bought a new mouse today and i am going to test it if the touchpad issue is gone. :wink:

Nope no differences, the sleep mode really likes my touchpad.
But now i noticed how i really needed a new mouse. :stuck_out_tongue_winking_eye:

Just to be sure:

modprobe psmouse

does not bring your mouse back after it’s had a problem

If that’s the case, I’m sorry, I can’t help you even with a workaround


Fabby the main problem (hanging after sleep) is gone.

The only thing now is that the touchpad is active in sleep mode but in normal mode it is deactivated.
For me it is ok now even if the touchpad shouldn’t be active in sleep.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.