Guide how to run Foldathome and FAHControl and contribute to model cures against COVID-19

I think you misunderstood and maybe I worded it wrong. I was saying that the link you posted was the first line of this topic.

Arch wiki article was the first but as usual with Arch wiki pages, it's dry, unfriendly and expects from users to have certain prior knowledge or experience. I saw on gamingonlinux that some Manjaro user followed it without success, so I shared how I did it, adding certain crutial details that arch wiki have missed, but also omitting some advanced stuff to simplify things.

1 Like

Gotcha. Yep very true about how unfriendly the arch pages are. I consider it a stroke of luck every time I'm able to understand a page on there. LOL

1 Like

Here an alternative way to install it. I somewhat found it to be the easiest solution. Except of one line, everything can be done in the GUI:

  1. Install fahclient and fahcontrol from the AUR

  2. Enable and run fahclient user service: systemctl enable --now fahclient --user

  3. Open fahcontrol and configure a new client connection.

  1. Save an close the dialog.

  2. When you click on the new entry in the "Clients" list it should ask you to configure the client.

image

  1. Enter your desired username and team id (261159 for Manjaro Linux) and press Save

image

  1. Done. Now you can change things like folding power (how many CPU's should be working on things), etc.

1 Like

Just some additional info on additional parameters that are adjustable:

General purpose extra slot options:

Name: client-type
Value: advanced
Enables you to get 0x22 work units. Otherwise only 0x17, 0x18 and 0x21 units are loaded.
Name: pause-on-start
Value: true oder false
Pauses the client/slot it is added under on start
Name: next-unit-percentage
Value: 100
Tells the client/slot at which completion percentage to load start loading the next unit.
Rule of thumb
Time to download WU / TPF = x
Round down x to the whole number and substract it from 100 to get the value you should use.
Name: max-unit
Value: 3 
Tells the client/slot to only work 3 units per day.

For Clients with more than 16 Threads: Currently not active!

Name: client-type
Value: bigadv 
Name: max-packet-size
Value: big 

Both option request extra large WU. Working fast and without pause is important here!

Example Usage:

config.xml
<config>
  <!-- Folding Core -->
  <checkpoint v='30'/>

  <!-- Logging -->
  <verbosity v='1'/>

  <!-- Network -->
  <proxy v='192.168.2.1:8080'/>

  <!-- Slot Control -->
  <pause-on-battery v='false'/>
  <pause-on-start v='true'/>
  <client-type v='advanced'/>
  <power v='full'/>

  <!-- User Information -->
  <passkey v='561651651651'/>
  <team v='45032'/>
  <user v='Example_User'/>

  <!-- Folding Slots -->
  <slot id='0' type='CPU'>
    <cpus v='6'/>
    <next-unit-percentage v='100'/>
  </slot>
  <slot id='1' type='GPU'>
    <gpu-index v='0'/>
    <next-unit-percentage v='100'/>
  </slot>
</config>

Comparison Data for different GPU's folding power
https://docs.google.com/spreadsheets/d/1vcVoSVtamcoGj5sFfvKF_XlvuviWWveJIg_iZ8U2bf0/pub?output=html#

3 Likes

@moson and @Takei, I added links to your posts to the first one, so the readers have all the info right on the start.

Had a few issues getting the GPU slot enabled.
For nVidia users, it makes sense to have the following packages installed:

cuda
opencl-nvidia-[your_driver_version]
ocl-icd
oclinfo
nvtop-git

Then, you'll have to make sure that the fah user is member of the video group:
sudo usermod -aG video fah

Then, I got error messages like

08:22:43:ERROR:WU00:FS00:Failed to start core: OpenCL device matching slot 0 not found, try setting 'opencl-index' manually

and

ERROR:exception: There is no registered Platform called "OpenCL"

in the log, and
cuda error cuinit(0) (cuda_error_unknown (code 999) - unknown error)
in the system info.

There is a somehow weird workaround to get OpenCL and CUDA being detected (see here):
You will have to stop the foldingathome service, then run
sudo clinfo
and afterwards, you can start the foldingathome service again, and the FAHclient will then detect OpenCL and CUDA properly.
No clue, why this procedure is necessary but now, the GPU is folding as well.
Unfortunately, it seems that there is no way to set the project to be worked on. It looks like the projects are chosen arbitrarily by the client and/or the server(s).

Normally you can but there's no specific category for COVID-19. So you will literally get any project instead. However, this is a good thing because while the bulk of machines will be completing work units for COVID-19 research it means the other projects still get a look in. Why for example should cancer research be completely curtailed? It shouldn't really :wink:

1 Like

And here's a solution for all people working on nVidia cards, in order to enable proper detection of CUDA and OpenCL.

First, run
/usr/bin/nvidia-modprobe -c0 -u

Then start the foldingathome service:
systemctl start foldingathome.service

Unfortunately, it is not possible to include the nvidia-modprobe command in the service file as it fails to execute at that point. It only seems to work after the graphical desktop has been fully loaded.

1 Like

Seems to be of no interest anymore. Looks like the Corona virus is already beaten. That's at least good news :smiley:

Looks like the foldingathome package has been flagged out of date? :neutral_face:

There's a new build been pushed by F@H with bug fixes and a specific COVID-19 project option that's why it's flagged out of date. The client you have will still find COVID-19 projects on the any setting in the meantime.

EDIT - The release announcement said it was also able to fold faster, I have found this to be true. I thought it was quick before, now it is :rocket:

Each fold on my GTX1080ti was taking around 55 seconds before, that has been reduced to 45 seconds so 0x22 core handling was clearly optimised. The CPU core ax07 remains exactly half the GPU folding speed on my Ryzen 5 1600 (90 seconds per fold using 10 of the 12 available threads) so it has seen some performance tweaks too. The viewer which could not connect to running tasks before and broken project links also now work properly in the windows client.

I have left mine on the any project setting, it is still downloading COVID-19 tasks predominantly. I have had a couple of Cancer Research and Parkinson's Disease ones in the last few weeks but don't actually mind that. All their research is equally as important.

1 Like

The only problem is, that when I went to settings to set COVID-19 cause:

it threw this error:

Screenshot-2020-04-17-21-00-53

but only for the first time. Next time it seemed to work fine, but when I check the option, nothing has changed. So I checked config, still nothing new. The option wasn't added.

I wonder, what if I add it manually? So I added:

-cause <string=COVID_19>

and restarted the service. Looks fine, but how would I know if it's working? The gui options seem to be broken anyway (if I set something, it is usually saved in config but gui still shows defaults as if it was not reading the config).

better report it to them on the F@H forum

For some reason the new version on the aur isn't recognizing my 1060. Reinstalling didn't work either :neutral_face:

Please read. Check your config if it has something like gpu v=false in it.
If you can't get it to work make a thread.

Nope, I also completely trashed opt/fah/ and reinstalled again with the gpu default value true...started the service and it autoconfigured to only slot0 for the cpu. I don't see a log anywhere...which is also weird.

All that stuff is now in /var/lib/private/fah. Easiest to connect to it via FAHControl or netcat.

Ok I managed to get it working again. This time I used all default values during sudo FAHClient --configure (instead of my own ones for the username and team number,) started the service, and now the slots appear to be auto-loaded correctly. I just connect via browser and modify back to my username and team number and that's also working. Log is also in journalctl.

Amazing how technology has advanced. On a GTX550Ti, one WU takes more than a day :frowning:

Looks like the last update broke something, at least in my case.

These are the packages that are available at AUR today (2020-04-21)

1 aur/foldingathome 7.6.9-5 [installed] (146) (35.23)
    A distributed computing project for simulating protein dynamics
2 aur/foldingathome-beta 7.6.10-2 (2) (1.00)
    Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related 
    diseases - beta version.
3 aur/foldingathome-openrc 20200319-1 (0) (0.00)
    OpenRC script for folding@home daemon
==> Introduzca el número de los paquetes que desea instalar (ejemplos: 1 2 3 ó 1-3)

After updating, mark an error when starting the service.

$ sudo systemctl start foldingathome.service

Job for foldingathome.service failed because the control process exited with error code.
See "systemctl status foldingathome.service" and "journalctl -xe" for details.

$ sudo systemctl status foldingathome.service
● foldingathome.service - Folding@home distributed computing client
     Loaded: loaded (/usr/lib/systemd/system/foldingathome.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Tue 2020-04-21 11:14:32 CDT; 1min 6s ago
    Process: 120415 ExecStartPre=/usr/bin/chown -R fah:fah /etc/foldingathome (code=exited, status=1/FAILURE)

abr 21 11:14:32 sandycheeks systemd[1]: Starting Folding@home distributed computing client...
abr 21 11:14:32 sandycheeks chown[120415]: /usr/bin/chown: usuario inválido: «fah:fah»
abr 21 11:14:32 sandycheeks systemd[1]: foldingathome.service: Control process exited, code=exited, status=1/FAILURE
abr 21 11:14:32 sandycheeks systemd[1]: foldingathome.service: Failed with result 'exit-code'.
abr 21 11:14:32 sandycheeks systemd[1]: Failed to start Folding@home distributed computing client.

It seems to be a problem with user fah, but that user does not exist and did not have this problem with the previous version.

Anyone else have this problem?

Update

Everything worked again by installing the foldingathome-beta package.

Forum kindly sponsored by