GUI modal mode of keyring request for password

Chromium sometimes request password confirmation of the linux keyring, “trousseau de clés” in French.

The linux keyring window is a modal GUI, that means that no other action can be performed than that very one. You can’t even save the documents you were working on, which have nothing to do with Chromium, for instance LibreOffice.

This can be problematic, because:
1/ I don’t remember the keyring password
2/ the only way to get around this modal GUI is to unplug the laptop and boot again.
And normally, when you launch again Chronium the password request to keyring is no more asked.

Suggest change:
Chromium GUI password request to keyring is no more a modal window, but a normal one.


XFCE 21.2.1

Install seahorse and go to Passwords and Keys > Default keyring > Right click Chromium > Properties and set the password to just blank:

sudo pacman -S seahorse
  • Open menu - xfce4-settings-manager - xfce4-session-settings - autostart
  • enable gnome-keyring

I did it, seems ok