GUFW Segmentation fault

kde
firewall
gui

#1

As the discussion on Stable Update started here:


And further investigations on unstable installs i have, it seems GUFW GUI doesn’t launch in KDE Plasma, but ends up in a segmentation fault.
Found this old treat on arch forums
https://bugs.archlinux.org/task/52599

I have no issues in Gnome and XFCE install, but the issue is present in KDE Plasma.

As reported bellow, the issue is present in that case also under Gnome.

A possible fix as mentioned later in the discussion ?!?!

Edit:
In KDE Plasma by running from terminal:
sudo gufw-pkexec
i can get the GUI with no error.


[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox
[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox
#2

I installed gufw to see what is happening on Illyria and it is the same as what @bogdancovaciu wrote above.
Starting gufw in terminal ends with a segmentation fault, running sudo gufw-pkexec starts the program normally.


#3

I am on gnome (testing) and have gufw installed

starting it from the UI (gnome-shell) as expected. Asks for password, than starts fine.

starting gufw from terminal -> asks for password, than starts fine.


#4

Same here:

  1. Gnome - working
  2. XFCE - working
  3. KDE Plasma - not working
    3a. with $ kdesu gufw-pkexec i get
    Icon theme "ubuntu-mono-dark" not found. and it takes a long time to open
    3b. with $ sudo gufw-pkexec and entering the password in terminal it opens instantly
    3c. any other method i get
(gufw.py:1508): Gtk-CRITICAL **: 12:59:46.820: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed
/bin/gufw-pkexec: line 13:  1508 Segmentation fault      (core dumped) python3 ${LOCATIONS[${i}]} $1

#5

what’s the output of
echo $PATH
and
which gufw-pkexec

as I said int the stable release announcement it seems in my KDE install
which gufw-pkexec return /bin/gufw-pkexec.
then the polkit rule/usr/share/polkit-1/actions/com.ubuntu.pkexec.gufw.policy is not applied as it specify /usr/bin/gufw-pkexec.

a work around is to run pkexec /usr/bin/gufw-pkexec


#6

when i “downgrade” filesystem/profile, its ok for which -a gufw and gufw of course
but why we have /bin only with kde ?

appendpath '/usr/local/sbin'
appendpath '/usr/local/bin'
appendpath '/usr/bin'
unset appendpath
# return to old version
PATH="/usr/local/sbin:/usr/local/bin:/usr/bin"

I have /bin in $PATH before etc/profile :thinking:


#7

it’s what I’m trying to find… :wink: where the PATH is overriden with /bin:/usr/bin:/usr/local/bin:/usr/local/sbin


#8
$ echo $PATH
/bin:/usr/bin:/usr/local/bin:/usr/local/sbin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
$ which gufw-pkexec
/bin/gufw-pkexec

with pkexec /usr/bin/gufw-pkexec it takes even longer to initiate than with kdesu gufw-pkexec as i mentioned initially …

I was wondering the same thing …
But mind you, this install is heavily exploited by me, and doesn’t quite play the way a stable install should be. Maybe @DeMus that has a fresh install if Illyria has a different output …


#9

it’s possible that polkit is slower than kdesu


#10

This is what I have:

echo $PATH
/bin:/usr/bin:/usr/local/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
[jan@manjaro ~]$ which gufw-pkexec
/bin/gufw-pkexec

#11

tests :
load plasma ,

  • in konsole,tilix : PATH is false
  • but after, open a tty3 : PATH is good in tty3 no /bin at first

:crazy_face:

my Archlinux, PATH is always good ! same 2 /etc/profile


#12

same here. and then in tty which return the right /usr/bin…
where the ■■■■ it’s changed… it’s the same on arch @papajoke ?


#13

it comes from sddm.conf in /etc.
I guess it’s the kcm for plasma settings that put it. as the default setting in /usr don’t have /bin.

no it does not seems to add it… :thinking:

after removing the PATH line in the [user] goup in my /etc/sddm.conf
this is my new PATH output.

echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

and gufw works as expected.

@kdemeoz


Testing Manjaro 18 Illyria KDE
Polkit and pkexec
[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox
When is dolphin going to be updated to use polkit?
[Stable Update] 2018-05-17 - GCC8, Gimp, KDE, Gnome, Deepin, Firefox
Polkit and pkexec
GUFW keymap error
#14

CONFIRMED!
Nice job :wink: Marked as solution too, and maybe someone will take care of this with the next update … or something :smiley:


#15

I created a pull request


#16

to add in wiki polkit break in plasma … (my english is too bad)


#17

done :wink:


#18

its again normal to have /etc/sddm.conf ? for me no ! view man sddm.conf

ps: i dont have with arch

NOW, i use /sddm.conf.d/ for personnal changes

ls /etc/sddm.conf.d/*;cat /etc/sddm.conf.d/*
/etc/sddm.conf.d/theme.conf  /etc/sddm.conf.d/user.conf
[Theme]
# Current theme name
Current=breeze

# Cursor theme used in the greeter
CursorTheme=Adwaita
[Users]

# Remember the session of the last successfully logged in user
RememberLastSession=true

# Remember the last successfully logged in user
RememberLastUser=true

# When logging in as the same user twice, restore the original session, rather than create a new one
ReuseSession=true

#19

to be honnest I don’t really understand the “new” policy about config files in /usr , /etc, etc.
for me if you modify the config that seems normal to be in /etc.

maybe the default config for the distro should be in /usr but not the same file as the package so…

does the module of plasma will use it if it exist? as for now it still use /etc/sddm.conf
then it’s problematic I think to have “both” that manjaro use “/sddm.conf.d” to set the “default theme etc” and aferwards the kcm module sddm.conf.


#20

yes, plasma create a new file /etc/sddm.conf
BUT
/etc/sddm.conf.d/* override this file

its a arch way :laughing: