GTK Application Style Icons Setting Missing in KDE System Settings

This is my first question so sorry if I do not comply with some guidelines, if you think so, I am happy to fix the cause of matter.

Last time i tried to set the icon theme for GTK/GNOME applications in system settings it looked like this: GTK Icons Option in KDE Settings

Now it looks like this:

So my question is just where do I find/set the GNOME/GTK Icons theme setting?

[filip@filip-linux ~]$ inxi -Fxxxz
System:    Host: filip-linux Kernel: 5.4.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.3 
           tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: 1.D0 date: 11/07/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86441 
           Speed: 2119 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2057 2: 3739 3: 2193 4: 2170 5: 2062 
           6: 2482 7: 2025 8: 2184 9: 2096 10: 3625 11: 1980 12: 2233 
Graphics:  Device-1: NVIDIA GF108 [GeForce GT 630] vendor: ZOTAC driver: nvidia v: 390.132 bus ID: 26:00.0 chip ID: 10de:0f00 
           Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: GeForce GT 630/PCIe/SSE2 v: 4.6.0 NVIDIA 390.132 direct render: Yes 
Audio:     Device-1: NVIDIA GF108 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 26:00.1 
           chip ID: 10de:0bea 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 28:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.4.28-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: f000 bus ID: 22:00.0 chip ID: 10ec:8168 
           IF: enp34s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 24.18 GiB (1.2%) 
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
           rev: SS0328D scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 0001 scheme: GPT 
Partition: ID-1: / size: 29.40 GiB used: 16.85 GiB (57.3%) fs: ext4 dev: /dev/nvme0n1p5 
           ID-2: /home size: 68.40 GiB used: 7.31 GiB (10.7%) fs: ext4 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 44.2 C mobo: N/A gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 52% 
Info:      Processes: 277 Uptime: 1h 19m Memory: 15.65 GiB used: 1.79 GiB (11.5%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           clang: 9.0.1 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37

KDE devs removed it and applied icons theme in icon settings for GTK apps also.

2 Likes

That is not great.

I know, try changing theme name inside ~/.config/gtk-3.0/settings.ini and restart the session.

Maybe it could work, unless Plasma decide to overwrite the settings.

Plasma system settings has some lacks unfortunately.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by