Grub will not install -- hanging at executing efibootmgr

I’m trying to install Manjaro on my portable hard drive, but it keeps failing when installing grub. Here is my setup. I’m booted into the manjaro live USB (manjaro 21.0.7) from a 16 GB HD. The host machine is a Macbook Pro 2019. The drive I’m trying to install on is a 1TB nvme SSD connected directly via USB-C. Internet access is provided via USB tethering with my iphone.

  • Originally tried to install along side windows using the graphical installer and the install alongside option.
  • Tried installing along side windows by manual partition method
  • Formatted the hard drive and tried installing via the graphical installer
  • Formatted the hard drive and installed using the command line only, following this guide
    In every case it fails while installing grub. When doing it via the command line, I can see that grub hangs up at executing efibootmgr -c -d /dev/sdb -p 1 -w -L Manjaro -l \EFI\Manjaro\grubx64.efi. There’s no error, it just hangs up there.

Search Macbook on this forum and you will see that you are not the only one. Mac has somehow a special behavior. The reason for failing is this: