Grub update unable to overwrite Debian's Grub


I have a problem with grub on two computers after updating debian (triple-boot debian/W**/Manjaro). I did make the same mistake twice… Grub has been updated by Debian and I cannot restore a normal manjaro grub and startup.

Starting with the easiest, and older tower computer with legacy Bios and a unencrypted partition. I did solve the problem of “kernel panic” and did manage to enter into Manjaro to work normally.
The problem is that none of the method to upgrade grub is working, Debian is still “dominating”. I did for instance update the kernel, the grub has been updated and all the OS’ recognized but I am still booting with debian’s grub. I had tried also some alternative from within Manjaro like reinstalling grub, erasing the current installation and reinstalling, disconnecting /dev/sdb to make sure to install and start with /dev/sda and so on but nothing is giving a result.

I understand that the chroot method should be considered only if I cannot enter into Manjaro and should not be applied here?

Thanks in advance for you orientations.

I believe there is/was a step-by-step guide to reinstall manjaro’s grub in such a case … but I do not have it on hand. it may have been at

I used to dual boot with a Debian derivative distribution (AVLinux) that used the standard Debian installer; with an option during install for user to prevent install of GRUB
AVLInux now uses MXLInux installer instead of the standard Debian installer, but has retained the option for users to not install GRUB

Debian should also allow for uninstalling GRUB so that updates do not include updating Manjaro GRUB
GRUB should be updated from Manjaro after any Debian update if the Debian GRUB is removed

If you cannot boot to Manjaro from GRUB updated by Debian you can boot from a Live USB and use chroot command to login to installed Manjaro OS

manjaro-chroot -a

and update GRUB from within installed Manjaro

I did find this in one of the archives and it worked…

sudo grub-install /dev/sda
sudo update-grub

It was rather simple because I was still able to launch Manjaro but I do not understand the difference with the following that FAILS to update…

sudo mv /etc/grub.d /etc/grub.d.bak
sudo pacman -S grub
sudo update-grub

Would this be working with my encrypted efi system also?
I would think something like launching with the usb key, mount the encrypted partition that contains the manjaro OS and then

manjaro-chroot -a

I didn’t consider encryption because it wasn’t mentioned in OP and I have never used encryption

All I can find from searching this forum is how to use a mount partitions manually and chroot
Reinstall grub + BIOS + fully encrypted LUKS partitions, will this work? - #22 by stephane

But this post from the archived forum suggests manjaro-chroot should also work as

How to chroot into an encrypted root partition - Tutorials - Manjaro Linux Forum
A viable alternative to manually mounting and chrooting

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.