Grub rescue issue after installation

I had Linux Mint previously installed.
Then I installed Manjaro Lysia. After the installation was concluded (no problems), I rebooted, but the following message appeared:

error: no such partition.
Entering rescue mode…
grub rescue>

I have to cold boot the machine.
I’ve tried to reinstall from the USB key, but the same message appeared.
When I go to the BIOS and select Mint in the boot order, Mint will function perfectly (I kept dual booting).
The problem is with Manjaro.
I tried to redo the live USB, but it didn’t work.

p.s.: I’m not some IT professional, just a regular user, Linux enthusiastic, but I performed Ubuntu and Mint installation by my own, as well as some minor troubleshooting.

Welcome to the forum! :slight_smile:

Lysia is already old. There was Kyria after that, and right now we’re on Mikah, and you’re bound to run into upgrade problems once you get Lysia up and running, because a lot has changed in the meantime.

Packages are now compressed with zstd instead of xz, and there have also been other major changes that could cause you to run into difficulties. For instance, GRUB was patched against the infamous Boot Hole vulnerability ─ which requires you to reinstall GRUB to the MBR or EFI system partition, depending on your setup ─ and now there has just been a serious upgrade to the PAM security system, which also brings its own set of problems to the table for certain users.

But that all said, your problem appears to be that GRUB cannot find the root filesystem. There could be multiple reasons for that, depending on what machine you’re on, how many drives there are, what partition table you’ve got, and so on. And ─ no offense, but I just have to say this ─ like most newbies to this forum, you seem to be under the impression that we have a crystal ball. I wish we did, but no, we don’t.

Best advice I can give you right now ─ and then I’m not getting into all of the difficulties I’ve mentioned higher up regarding the fact that your install .iso is outdated ─ is to boot up from the USB key in live mode and check the UUID of your root partition, and then compare that to what GRUB expects.

You can use the manjaro-chroot tool on the live medium to autodetect your Manjaro root filesystem, and then chroot into it, so that you can more easily edit /etc/default/grub with the correct UUID for your root filesystem ─ as well as /etc/fstab ─ and then run update-grub against the correct GRUB installation, because if you also have Mint on that system, then that will have its own GRUB, and you don’t want to update that one.

I’m afraid that’s as much as I can tell you with the scant information you’ve provided us with. :man_shrugging:

Thank you for your answer.
I do know there’s no crystal ball, specially when you’re not in front of the machine, just dealing with the given information.

I must correct myself: I installed version 20.0.3 (downloaded the iso yesterday from the site).
I tried to boot from a live USB before, but it displayed the same error message.
I even formatted and rebuilt the live USB, to be sure it wasn’t the issue

So you are saying that it cannot even boot from the live USB? :astonished:


Are you sure it’s trying to boot from the USB stick and not from the internal drive? Because I don’t think the boot loader on the USB stick would be GRUB. :thinking:

When it’s initializing, I hit F2, Go into the BIOS settings, change the boot order, set USB to #1, and it still gives the same message.

Well, if it worked at first and now it no longer does, then that suggests a hardware problem. :thinking:

Thank you for your time though.
I’ll keep trying for a while.
If it doesn’t work now, I’ll give Manjaro another chance later.
I was in the Ubuntu system for a while. Now I’ve decided to expand on that.
Always learning

I’ll leave here the machine specs (from Mint) as a register:

System:    Kernel: 5.4.0-45-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 
           wm: muffin dm: LightDM Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Laptop System: SAMSUNG product: 700Z3A/700Z4A/700Z5A/700Z5B v: 0.1 
           serial: <filter> Chassis: type: 9 v: 0.1 serial: <filter> 
           Mobo: SAMSUNG model: 700Z3A/700Z4A/700Z5A/700Z5B v: FAB1 serial: <filter> UEFI: Phoenix 
           v: 15FD date: 11/06/2012 
Battery:   ID-1: BAT1 charge: 53.3 Wh condition: 53.3/65.1 Wh (82%) volts: 16.4/14.8 
           model: SAMSUNG Electronics serial: N/A status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-2450M bits: 64 type: MT MCP arch: Sandy Bridge 
           rev: 7 L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19955 
           Speed: 2948 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 3017 2: 3085 3: 2893 
           4: 2894 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
           vendor: Samsung Co driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126 
           Device-2: AMD Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] vendor: Samsung Co 
           driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6741 
           Display: x11 server: X.Org 1.20.8 driver: ati,modesetting,radeon unloaded: fbdev,vesa 
           resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 20.0.8 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Samsung Co 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Sound Server: ALSA v: k5.4.0-45-generic 
Network:   Device-1: Intel Centrino Advanced-N 6230 [Rainbow Peak] driver: iwlwifi v: kernel 
           port: 3000 bus ID: 02:00.0 chip ID: 8086:0091 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Samsung Co 
           driver: r8169 v: kernel port: 2000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 294.36 GiB (31.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB 
           speed: 3.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 611.78 GiB used: 291.97 GiB (47.7%) fs: ext4 dev: /dev/sda2 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
           chip ID: 8087:0024 
           Device-1: 1-1.4:3 info: Silicon Motion type: Video driver: uvcvideo rev: 2.0 
           chip ID: 2232:1018 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
           chip ID: 8087:0024 
           Device-2: 2-1.2:3 info: Logitech Unifying Receiver type: Keyboard,Mouse 
           driver: logitech-djreceiver,usbhid rev: 2.0 chip ID: 046d:c534 
           Device-3: 2-1.3:4 info: Intel type: Bluetooth driver: btusb rev: 2.0 chip ID: 8086:0189 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 83.0 C mobo: N/A gpu: radeon temp: 29 C 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/bitseater-ppa-focal.list 
           1: deb http: // focal main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http: // ulyana main upstream import backport
           2: deb http: // focal main restricted universe multiverse
           3: deb http: // focal-updates main restricted universe multiverse
           4: deb http: // focal-backports main restricted universe multiverse
           5: deb http: // focal-security main restricted universe multiverse
           6: deb http: // focal partner
Info:      Processes: 220 Uptime: 6m Memory: 5.72 GiB used: 1.25 GiB (21.8%) Init: systemd v: 245 
           runlevel: 5 Compilers: gcc: 9.3.0 alt: 7/9 Client: Unknown python3.8 client 
           inxi: 3.0.38 

obviously seem to be issue with usb. try to format it, then [install ventoy in the usb, then copy pase any iso or tools you need, check if ventoy boots and displays the list of iso you copied, just sharing my experience as we dont need to keep flashing with the new iso, just download and copy paste into ventoy. just felt to share this L I N K

I managed to finish the installation with a new iso.
I worked just fine, but when I turn off and turn on again, I get stuck in a log in page, where I type the password, type enter, but nothing happens (the forum doesn’t allow me to post links or pictures here).

Please open a new topic for a new problem.

Please use the 20.1-rc5 .iso ─ it fixes the stuck login issue.