Grub recovery when booting from usb

When I try to look up this problem I only find solutions for people who are dual booting and their windows installation somehow screwed up the Linux one, but I am not dual booting. I have win10 and I wanted to try some Linux distros. First I tried Linux mint cinnamon and it ran fine from USB, then I tried to boot manjaro gnome from USB and I kept getting grub recovery: grub disc native sector not found, I also tried an older version of manjaro but no luck. Can someone help me with this preferably as simply as possible since I don’t have much experience with Linux.
Thanks in advance.

I guess you are doing something wrong when writing the ISO to USB. Better see this

Or maybe you prefer to use Ventoy and that way you can have multiple ISO files on the same stick, and no need to deal with the rescue menu …

Thanks, i didn’t know that i was supposed to use dd instead of the standard writing mode.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.