Grub-probe: error: cannot find a GRUB drive for /dev/sda1

I have been having sudden issues with launching Manjaro. When launching, it gets stuck at the Dell logo. I have tried to use update-grub but it results in the following message:

Generating grub configuration file …
Found theme: /boot/grub/themes/blur-grub2-hd/theme.txt
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

To be clear, I am booting from a usb stick and using chroot. I have dual-booted with Windows 10, and so I believe it is likely that a Windows update is what broke Manjaro.

Try to reinstall grub using live and chroot

If you mean using grub-install I have already tried that and it did not help

How did you reinstall the grub?

From my live usb I used manjaro-chroot and followed these instructions from a previous thread:

sudo pacman -Sy msdos os-prober
sudo manjaro-chroot -a ( type 1 if only one line appears )
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --verbose
efibootmgr -v
exit ( end chroot )

grub-install gives no errors, but update-grub then prints the previously mentioned errors.

After booting the live ISO please post the output of following commands to be enteerd in a terminal:

sudo parted -l
lsblk -f
sudo efibootmgr -v

1st command:
Model: SanDisk Ultra USB 3.0 (scsi)
Disk /dev/sda: 30.8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2773MB 2777MB 4194kB primary esp

Model: PM981 NVMe Samsung 512GB (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 683MB 682MB fat32 EFI system partition boot, esp
2 683MB 817MB 134MB Microsoft reserved partition msftres
3 817MB 164GB 163GB ntfs Basic data partition msftdata
8 272GB 492GB 220GB ext4
9 492GB 496GB 4295MB linux-swap(v1) swap
4 496GB 497GB 1038MB ntfs hidden, diag
5 497GB 511GB 13.9GB ntfs hidden, diag
6 511GB 512GB 1226MB ntfs hidden, diag

squash 4.0 0 100% /run/miso/
squash 4.0 0 100% /run/miso/
squash 4.0 0 100% /run/miso/
squash 4.0 0 100% /run/miso/
sda iso966 Jolie MANJARO_GNOME_2003
│ 2020-06-06-09-50-25-00
│ iso966 Jolie MANJARO_GNOME_2003
│ 2020-06-06-09-50-25-00 0 100% /run/miso/

│ vfat FAT32 ESP DCC6-EFDD

│ ntfs OS F48226FB8226C1CA
│ 7AB21F1DB21EDD87
│ ntfs Image 24C81F50C81F201A
│ F8DAD97ADAD9361A
│ ext4 1.0 7d28cade-4cca-468b-b448-aaa7d255735c
swap 1 41be8627-b6e4-41f3-a695-3fb079d78cbd

3rd command gives no output.

BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0002,0004,0000,0005
Boot0000* Windows Boot Manager HD(1,GPT,96895829-1f74-4347-9097-f7677c699407,0x800,0x145000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}…
Boot0001* Linux Firmware Updater HD(7,GPT,5d5038b5-1237-4d08-bdb2-1b5490358eaf,0x2d3d6800,0xfa000)/File(\EFI\ubuntu\fwupdx64.efi)
Boot0002* manjaro HD(1,GPT,96895829-1f74-4347-9097-f7677c699407,0x800,0x145000)/File(\EFI\manjaro\grubx64.efi)
Boot0004* deepin HD(1,GPT,96895829-1f74-4347-9097-f7677c699407,0x800,0x145000)/File(\EFI\deepin\shimx64.efi)
Boot0005* UEFI: SanDisk, Partition 1 PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(1,MBR,0x0,0x52a0a0,0x2000)…BO

This can be ignored as it’s linked to the USB stick. So, everything looks OK.

Next time, boot into firmware and select the Manjaro entry to boot from it, permanently.

But I’m still not able to launch manjaro? It gets stuck at the Dell logo

If it’s still not working check if Secure boot is enabled in firmware (disable it) or if Fastboot has been enabled in Windoze which could leave the disk in a hibernating state hindering you to use it properly for other OS. This needs to be switched-off from within Windoze.

secure boot is already disabled. I can’t see the Fastboot option in Windows, and using powercfg /hibernate on (to turn on the fastboot option) results in the following:

Unable to perform operation. An unexpected error (0x65b) has occurred: Function failed during execution.

Maybe my post was unclear but Fastboot must be switched off.

1 Like

I understand, but the option to disable it is simply not there

If you disable hibernation, then you disable fast boot (fast boot is a hibernation mode). Probably you already have hibernation disabled, but just in case: powercfg /h off in administrator mode

In grub menu, edit the Manjaro entry and remove the quiet word from linux line. And boot it with F10. Maybe that will give more information

I did this, but it had no effect on the problem.

How do I edit the grub menu? Seeing as I am unable to use my OS

chroot into your system again and edit the file /etc/default/grub.

Afterwards (still in chroot) enter


and try to reboot.

When in grub’s menu, select with the cursor keys the entry you want to edit and press ‘e’ (

PS: I can’t embed images

I have now tried this, but it seems to have no effect what so ever.