Grub password prompt is not shown, when chained after Clover

Hey,

I’m currently working on a encrypted dual boot hackintosh with a chained bootloader CLOVER -> GRUB2. Individual both work great but combined I’ve got some graphic problems.
CLOVER works, but when loading the encrypted (is it encypted?) grubx64.efi the password prompt isn’t shown anymore. It still works, when entering the correct password GRUB is shown.

Here’s a video of the behavior:

System:

OS: Manjaro Linux x86_64 
Host: Z370N WIFI 
Kernel: 4.14.74-1-MANJARO 
Resolution: 2560x1080 
DE: Xfce 
WM: Xfwm4 
CPU: Intel i7-8700 (12) @ 4.600GHz 
GPU: NVIDIA GeForce GTX 1060 6GB 
Memory: 2428MiB / 15994MiB

Grub config:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet cryptdevice=UUID=ae1756fe-1f42-417c-935d-cb95cc8f3255:luks-ae1756fe-1f42-417c-935d-cb95cc8f3255 root=/dev/mapper/luks-ae1756fe-1f42-417c-935d-cb95cc8f3255 resume=/dev/mapper/luks-ae1756fe-1f42-417c-935d-cb95cc8f3255"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# GRUB_GFXMODE=auto

# changed by me, but had no effect
GRUB_GFXMODE=2560x1080 

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
GRUB_ENABLE_CRYPTODISK=y

relevant Clover pList Entry:

<dict>
	<key>Disabled</key>
	<false/>
	<key>FullTitle</key>
	<string>Manjaro</string>
	<key>Hidden</key>
	<false/>
	<key>Ignore</key>
	<false/>
	<key>Path</key>
	<string>\EFI\Manjaro\grubx64.efi</string>
	<key>Type</key>
	<string>Linux</string>
	<key>Volume</key>
	<string>FC290B65-1A4B-4DA6-8F93-845406E550DC</string>
	<key>VolumeType</key>
	<string>Internal</string>
</dict>

Hackintosh issues should be addressed to the “dedicated” forum, not here. In the same time, multipurpose custom boot loader issues should be addressed to the developers of it, or simply check the documentation. With all that said, i’ll give you a hint.
Manjaro prefers to use it’s default boot loader for whatever multiboot systems installs.
Some info about here and here and another one here
Boot issues with Manjaro and it’s particularities: encrypted or non encrypted, can be addressed here, and you will receive the proper replies; but you don’t have such issue.


Personally i think this topic is way off topic and the purpose of this forum.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark