GRUB not working on IDE-SD adapter

Man that worked! I’ve been able to boot into the installed system without problems. I tried to install grub on the fly, but it wasn’t effective and after the reboot the machine still said “Operative system not found”, but anyways that’s a step forward. Now I don’t have time to try again better, but tonight or tomorrow I’ll try it again and I’ll update you.

3 Likes

Now after booting into the system, there’s more you need to do.
First update your installation with pacman-mirrors, Syyuu.
Check (always verify when you do this) what is the insternal disk (one disk? - still do this) is.
lsblk -f , parted -l, fdisk -l, …
Then do (if sda is the internal disk)
sudo grub-install /dev/sda
sudo update-grub

Then fix your graphics (if required) and other things.
I’ll leave you at this point.

Take care.

2 Likes

You have to consider that a hardware incapability or malfunction/damage is possible, either on the SDcard, or the laptop hardware/BIOS.

This may be the reason for the problem.
Consider

  • checking the SDcard for defects
  • research your motherboard/BIOS capabilities.
  • try with another card, when available.
  • prepare for a permanent problem (some time you will need to re-install Grub)

OP didn’t say (neither did he say this isn’t a problem anymore) he still have the error after he set swap to 2nd partition, not the first.
He did say a few new errors after that, not this. But to get the new errors, this shouldn’t be a problem anymore. And the new errors are indicative that he could (but didn’t) boot to the OS.
Yes, it is ffrustrating to read among (not between) the lines. Hope people can be clearer, but then it is surely not intentional. So let us understand and go pass it.

That is the result of doing the command from the livecd boot, not the installed OS boot.
As I pointed out somewhere.
Again OP didn’t say he did it from livecd, but I know from the output it is from livecd.
It is not the reason for the problem.

It’s okay, petsam, sometimes we ourselves are not clear, and because we don’t know we are not clear. No malice or deliberate obfuscation. It’s alright.

1 Like

Hi, I just tried again calmly, but after rebooting the problem is still the same.
I followed your steps, so

  • checked for updates with pacman-mirrors and pacman -Syyuu, but everything was updated
  • checked with parted and the SD was labeled as sda as expected
  • checked if everything was ok in /boot/ and it was
  • installed grub without errors and updated it
  • checked in /boot/ and /boot/grub and all looked fine. grub.cfg seemed to contain the correct data, and it was referring to the correct files located in /boot/

graphics and the system in general was perfect, so nothing to fix.
But when i rebooted the machine it was back to zero.

I don’t think the SD is faulty, neither that the BIOS is not capable: I used Arch for a while with this same setup and I’ve never had any issue. Also debian run fine when I tried it.

I apologize if I’ve been not so clear. If it still happens, please let me notice it and I’ll integrate with what is needed. Thank you again for your time.

Man I just installed Syslinux and averything runs perfect. I’ll get over it.
Thank you again for your time

2 Likes

Have you ever installed grub, when in those other distros?

What works is the best way for each one! :wink:

Good to hear it is working well in syslinux.
And no worries, you’re alright.
I guess that when we have to wonder what’s up with the SD card which you refer to it at the beginning of the topic and you do not explain the adapter. :smile:

But can you print out for us the syslinux entry that works well for you.

It may point to something that grub does not.

Thanks.

PS: as grub boots okay following the manual input( my post), I think it can work well too.
You system generated grub cfg is also good to have if you still have it.

2 Likes

What do you need? the syslinux.cfg file?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark