GRUB not working on IDE-SD adapter

Yes, because the SD in the adaptor shows up like an IDE disk, that’s the difference.
You can boot from an SD inserted into a usb adapter because your pc supports usb boot. I’ve never heard about built-in SD reader boot

1 Like

If you are sure it can pick up the disk at bios, try to set partitioning to it using gparted.
Device tab… Create Partition table … Msdos…then create some partitions.
Note it will erase all data in that disk.
Then boot livecd and see if the partitions are now shown.

If you need data in that disk and you do not want to erase them, use another SD card for this experiment.
But …that data is useless anyway if you can’t use it.

Let us know, ya.

Sure, there is nothing important in the SD now.
I’m doing a new install, just to post for comparison purpose the fdisk and parted output before rebooting the machine. As soon as it ends I’ll post it

Ok, after a new install, the outputs are like this:

> parted -l
Model: ATA SINTECHI HighSpe (scsi)
Disk /dev/sda: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  2149MB  2147MB  primary  linux-swap(v1)
 2      2149MB  32.0GB  29.9GB  primary  ext4            boot


Model: UFD USB Flash Drive (scsi)
Disk /dev/sdb: 15.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  1618MB  1618MB  primary               boot
 2      1618MB  1622MB  4194kB  primary               esp
> sudo fdisk -l
Disk /dev/loop0: 62.4 MiB, 65380352 bytes, 127696 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 197.7 MiB, 207273984 bytes, 404832 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 816.3 MiB, 855986176 bytes, 1671848 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 415.1 MiB, 435290112 bytes, 850176 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 29.8 GiB, 32010928128 bytes, 62521344 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xdefa770e

Device     Boot   Start      End  Sectors  Size Id Type
/dev/sda1          2048  4196351  4194304    2G 83 Linux
/dev/sda2  *    4196352 62521343 58324992 27.8G 83 Linux

Disk /dev/sdb: 14.6 GiB, 15699279872 bytes, 30662656 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdb1  *         64 3159627 3159564  1.5G cd unknown
/dev/sdb2       3159628 3167819    8192    4M ef EFI (FAT-12/16/32)

All the partitions are kept in any situation after reboot (gparted live, fdisk, parted, other formatters on win/mac).
If I install manjaro (or arch, it doesn’t mind) but I don’t install grub, and I reboot, every single file is kept. But as soon as I install grub everything explodes.

How did you install grub?
From your Live installer?
If yes, try again (I know it’s a PITA, but…) the same, but do not install grub at all.
Reboot again in the Live installer and

  • Boot to the installed Manjaro using the method in the Tutorial.
  • See if it runs well.
  • Run a complete update (pacman -Syyu) and reboot.
  • Again, boot to the Installer and use it to boot to the installation.
  • Run in the terminal
sudo grub-install /dev/sd{proper letter after check}
sudo update-grub
  • Reboot and try (finally) to boot to installation normally (unplug USB installer 1st)

If you cannot get to your installation as explained, try to do the same with chroot.

1 Like

A suggestion… Do not put swap as the first partition in an msdos partitioned device.
All other partitions use the first sector for bootloader thingies,
The first sector of a device is the mbr.
Swap uses all the partition. It does not have a first sector.

So if you use swap as the first partition, and it does not have the first sector, it means you cannot set 'pbr to it or 'mbr.

Try again. start again with gparted device tab…created partition table…msdos….make partitions.

Swap not in first partition. why not make more partitions? oh 32 GB? good enough.

2 Likes

Ok, I’m trying a new install with the swap partition in second position, grub installed via architect. If it doesn’t work I’ll try installing again installing grub via chroot/the tutorial way suggested by petsam. I’ll keep you updated.
I’m using just two partitions mainly for two reasons: they’re faster to create during this long sequence of installations, and anyways I just wanted to keep it simple. What partition scheme do you suggest?

how about scrapping the swap partition and using a swapfile in a single ext4 partition spanning the entire SD card? that should work

1 Like

Ok, some bad news for you:

Partitioning with the swap partition in second position didn’t change anything. Still same “Operative system not found”.

I tried a new install without installing grub as suggested by petsam. This time search.file /etc/manjaro-release root outputs nothing. search.file /etc/manjaro-release instead outputs hd1,msdos.
After that if I try configfile /boot/grub/grub.cfg it simply clears the grub console, ending with a clean screen and a grub> prompt at the top.

I noticed that the live usb grub splash notices an existing os and shows up a menu entry in order to boot it up, but if I select it, it just takes me to a black screen and nothing more happens.

I think I have already tried yesterday the single partition with swapfile, but after all these tries I don’t remember well, and I’ll give it a try.

Do this and on the black screen go to TTY (Ctrl+Alt+F3), login and startx.
Report any errors.
If all fail, try to chroot to the installation.
When you boot, does your BIOS (with shortcut pressed) see the device as an option? (for info, don’t select it)

Have you tried this with syslinux. Older may actually be better in this case. Sorry, but my syslinux skills are very rusty. I used to really like syslinux, but it’s been a long time since I’ve used it.

No success for the single partition install

Yeah, I’ll do a few other tries with grub, then I’ll try it for sure. But if it is possible I’d really wanna know why grub isn’t working well before

1 Like

Nope, It is good news.
As follows…

But after installing grub, nothing explodes, right?
Not like this? Before?

The partitions remain now that the swap is not in first partition?
You should say so, if something goes right.

Now as for the new problem (you did not encounter this before as ‘everything exploded’)…

So it is there, your OS is there. Not like before.
You just cannot configfile the grub. And take you back to grub.

Now, isn’t that an improvement?

You don’t need to redo with swap file. You can continue to try to get it working.
I need another break.

@petsam, you want to take over?
His OS is there, just make sure he uses the right kernel/initramfs file and other parameters to make it boot.
Suggest he boot to prompt first (‘3’) to convince him he can boot up.
OP mind is set for failure.

32 bit OS, any special things needed? I lost touch with 32 bit for some time.

1 Like

It doesn’t matter where I place the swap position: in any configuration, if I don’t install grub everything remains as it should be.

I’m installing again with the two partition setup to try petsam’s tty suggestion, but I believe there’s no tty there, just a black screen: no os loading before.

Anyways, I’ll try then to chroot from the live media and install grub from there. I’ll keep you updated.

PS: Thank you all for the time you’re dedicating to me and my problem, I really appreciate it

@lionhead, to boot to prompt (like tty, just more certain than ctl + alt + some F key),
After you get to manjaro grub menu, instead of pressing enter, press ‘e’ to edit.
Arrow down to linux line.
Remove everything except ‘rw’ and the linux kernel.
Remove resume=xxxxxxxxxx, quiet, splash, everything else. except kernel and rw.
And add ‘3’ (without apostrophes)
You should boot to prompt.
Login with password
Then pacman-mirror/update/upgrade
Fix what needed to be fix.

After doing…

grub> search.file /etc/manjaro-release 

You must do a second time, this time with root

grub> search.file /etc/manjaro-release root

I think you typed wrongly last time. Maybe.
then chekc your kernel with

grub> ls ($root)/boot/

At the manjsro entry, pressing ‘e’ recheck kernel is correct as listed in your ‘ls’ output.

If configfile command gives nothing, (or returns to grub prompt) don’t worry…
We can use like follwoiing to tnboot

grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.xx.xxxxxxxx root=UUID=$abc rw  3
grub> initrd /boot/initramfs-4.1xxx.xxxx.img
grub> boot

[edit] forgot the ‘3’, added above.
[ERRATA] - added above probe -u and root=UUID=