GRUB not loading after booting to Windows

I am having a hassle with GRUB since the installing Manjaro from SSD itself via rEFInd.
After installing manjaro and deleting the liveusb-like partition in the disk, the grub has entered into rescue mode. I’ve solved this via manually searching all the partitions in GRUB via ls and booting into the one that it recognized, which is Manjaro. I’ve not had encountered such a problem after that.

the real problem that persists is… I cannot get booting screen after selecting Windows once in the screen. For the next time, I need to go booting options with F12, then selecting the manjaro disc (and no, ESC or Shift is not working to invoke grub). After that, I can get the boot selection screen of GRUB.
I’ve done a clear install of GRUB again, as outlined in the last sections of org /t/using-livecd-v17-0-1-and-above-as-grub-to-boot-os-with-broken-bootloader/24916 . I’ve also modified the following entry as such

I’ve even set windows {bootmgr} as pointing to manjaro’s one, but it didn’t help, either. Note though, I’ve not directly installed GRUB next to Windows Boot Manager as it might mess with that, just created another separate UEFI partition.

edit: grub doesn’t load in manjaro either (worked after reinstalling again, though doesn’t show that fancy manjaro ui rn) and giving out hibernation error (solved after pointing to swap) after disabling fast startup and reinstalling grub as mentioned above.

it’s solved after removing boot and esp flags from windows boot manager via gparted.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.