Grub: "no such cryptodisk" error every time I reboot

Every time I reboot my laptop I get thrown into grub rescue:

Attempting to decrypt master key…
Enter passphrase for hd0, gpt2 (disk uuid)
error: access denied.
error: no such cryptodisk found.
error: disk ‘cryptouuid/uuid’ not found.
Entering rescue mode…

I reinstall grub using the wiki article and chroot in

Everything goes smoothly until I have to do “mount -t efivarfs efivarfs /sys/firmware/efi/efivarfs” where it gives me the error “no such mount point”

ls /sys/firmware/efi verifies that the efi filesystem is loaded though

so I do mkdir -p /sys/firmware/efi/efivarfs and it says “Cannot create directory: read-only file system”.

I can’t find anything to do about that error so I abandon it and move onto the next step the wiki tells me to do which is reinstall grub again.

Sometimes it works when I initially reboot but never the second time after the grub reinstallation.

This is the third time today I’ve reinstalled grub…

trying to reinstall grub for the 4th time today

]# cryptsetup luksOpen /dev/sda2 crypto
Enter passphrase for /dev/sda2: * I enter the passphrase *
No key available with this passphrase.

I entered the passphrase 9 times and went slowly twice and it gave me the same error every single time.

I think my ssd is ■■■■■■■

Hey @helios :wink:

Normally the key file is saved here by default with calamares:


If that file is not there and you don’t have a copy of it, i guess it is not possible to mount it.

I was able to mount it 20 minutes before though and the only thing that’d changed was a reinstallation of Grub so something’s gone wrong.

Thanks for your help.

Did you ever backup the LUKS header at any point for sda2? Is sda2 strictly a root partition (for the OS), or does it also contain your /home directory? Do you have any backups of such data if it is indeed /home?

No I didn’t back it up. Sda2 is root and /home and I didn’t back it up. I’m fine with losing my data because I back up everything important.

I ran SMART on my disk and there were nearly 790k raw on Program_Fail_Cnt_Total so my guess is that I can’t write on the disk anymore.