Grub-no list of OS choices on start up

Hi. I installed Manjaro KDE 17.1.10 on Friday, June 8, 2018. After getting help updating it, I restarted and was met with the following, instead of a list of OS choices:

GNU GRUB version 2.02~beta2-36ubuntu3.14

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

grub>_

I was able to exit, then find my way to what appeared to be a grub installation that lists my two OSes, then I booted into Manjaro and did a sudo update-grub. I then restarted and got a screen with the same message above. Any ideas what I can do to get the right grub to load on start up? Thanks.

The grub is from your Ubuntu OS, not Manjaro.
Look at the first post here and you use that ubuntu grub prompt instead of needing to boot up Manjaro live cd. And you can start at step 4. Read the whole of first post.

Are you clear if your system is uefi or bios-legacy? That will help (you).
Good luck.

ps: your ubuntu grub version is outdated.

Thanks for your help. I followed the instructions, but got the same result - still see the screen described above with “…grub>” at the end, although when I “exit” out I get a grub boot menu with manjaro as an option. And, yes, it is uefi.

Aha, your manjaro bootentry is 2nd after ubuntu’s. It’s there.
What’s
efibootmgr

and computer make and model?

How do I identify efibootmgr?

HP 15634 Laptop, AMD A6 Series, Model 15-af131dx

Bootup to Manjaro (you may have to type ‘exit’ at Ubuntu’s grub prompt)
At terminal, first do

sudo pacman-mirrors -f 5
sudo pacman -Syyu

When done, (as per the link), enter these commands and give us the output with your input commands.

LANG=C
efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi


note: ‘parted -l’ --> small ‘L’ and provide information of all disks.
And please print, not screen shots.

OK, I think this is what you asked for:

[cpossessky@cpossessky-pc ~]$ LANG=C

[cpossessky@cpossessky-pc ~]$ efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0003,3003,0001,0000,2001,2002,2003
Boot0000* manjaro HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\Manjaro\grubx64.efi)
Boot0001* Windows Boot Manager HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…/…
Boot0002* ubuntu HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\ubuntu\grubx64.efi)
Boot0003* ubuntu HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* USB Drive (UEFI) RC
Boot2002* Internal CD/DVD ROM Drive (UEFI) RC
Boot3000* Internal Hard Disk or Solid State Disk RC
Boot3001* Internal Hard Disk or Solid State Disk RC
Boot3002* Internal Hard Disk or Solid State Disk RC
Boot3003* Internal Hard Disk or Solid State Disk RC

[cpossessky@cpossessky-pc ~]$ sudo parted -l
Model: ATA HGST HTS545050A7 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 274MB 273MB fat32 EFI system partition boot, esp
2 274MB 408MB 134MB Microsoft reserved partition msftres
3 408MB 290GB 289GB ntfs Basic data partition msftdata
7 290GB 320GB 30.0GB ext4
8 320GB 324GB 4000MB linux-swap(v1)
9 324GB 406GB 82.4GB ext4
4 406GB 478GB 71.3GB ntfs Basic data partition msftdata
5 478GB 478GB 890MB ntfs hidden, diag
6 478GB 500GB 21.7GB ntfs Basic data partition hidden, diag

Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sdb: 61.6GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 61.6GB 61.6GB primary fat32 boot, lba

[cpossessky@cpossessky-pc ~]$ sudo blkid
/dev/sda1: UUID=“1C8C-A2B5” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“5e373847-3d45-4681-a83f-a14563aa6e68”
/dev/sda2: PARTLABEL=“Microsoft reserved partition” PARTUUID=“d5d6f0aa-2a2f-4a40-9be8-1859e550ad6b”
/dev/sda3: LABEL=“Windows” UUID=“14C479E4C479C88E” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“fc1ce7fc-14ba-42ba-8ba6-4c80c2d0f0a6”
/dev/sda4: LABEL=“New Volume” UUID=“C4C0AC26C0AC2122” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“2be4de7b-c84e-48d3-a804-e6dfb281ca08”
/dev/sda5: UUID=“CA22360A2235FC4F” TYPE=“ntfs” PARTUUID=“a07024c0-7292-4598-b6f5-bbbdd2a842f6”
/dev/sda6: LABEL=“RECOVERY” UUID=“E0B8DA40B8DA14BE” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“ea3a64b4-1b64-4cf2-8742-9d633c653ae7”
/dev/sda7: UUID=“190e21d8-e914-4ffc-993b-791f03d765e7” TYPE=“ext4” PARTUUID=“19dedcee-c4f3-47f7-90c1-b1abb00ea2ae”
/dev/sda8: UUID=“1ddf9e11-05fd-4fed-8db6-9b807bec0674” TYPE=“swap” PARTUUID=“8ee2970b-f186-4eb7-a9b7-180856795d55”
/dev/sda9: UUID=“b89456a7-7f53-4c90-b3da-f52841ed3ca1” TYPE=“ext4” PARTUUID=“b9ae7734-bbaa-40ef-95ba-3ab79b7cc148”
/dev/sdb1: LABEL=“LINUX MINT” UUID=“1509-1A46” TYPE=“vfat” PARTUUID=“000baac1-01”

[cpossessky@cpossessky-pc ~]$ findmnt -s
TARGET SOURCE FSTYPE OPTIONS
/boot/efi UUID=1C8C-A2B5 vfat defaults,noatime
/ UUID=190e21d8-e914-4ffc-993b-791f03d765e7 ext4 defaults,noatime
swap UUID=1ddf9e11-05fd-4fed-8db6-9b807bec0674 swap defaults,noatime
/home UUID=b89456a7-7f53-4c90-b3da-f52841ed3ca1 ext4 defaults,noatime

[cpossessky@cpossessky-pc ~]$ findmnt /boot/efi
TARGET SOURCE FSTYPE OPTIONS
/boot/efi /dev/sda1 vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

Okay, at Manjaro terminal, do the following…

And if there is any error (hopefully not), also print out the error message.

LANG=C
sudo efibootmgr -b 3000 -B
sudo efibootmgr -b 3001 -B
sudo efibootmgr -b 3002 -B
sudo efibootmgr -b 3003 -B
sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
efibootmgr -v

Reboot. Okay now?
Good luck.

ps: I’ll log off within a hour (sleep time). Take your time.
I’ll reply you tomorrow after getting your reply.

Thanks. You’ve been a great help. I appreciate it. I can’t get to this now anyway, I’m at work and need to get some work stuff done. I’ll do this later.

Nope. Still boots into screen described above. Here is output of all commands:

[cpossessky@cpossessky-pc ~]$ LANG=C

[cpossessky@cpossessky-pc ~]$ sudo efibootmgr -b 3000 -B

[sudo] password for cpossessky:
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0003,3003,0001,0000,2001,2002,2003
Boot0000* manjaro
Boot0001* Windows Boot Manager
Boot0002* ubuntu
Boot0003* ubuntu
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3001* Internal Hard Disk or Solid State Disk
Boot3002* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk

[cpossessky@cpossessky-pc ~]$ sudo efibootmgr -b 3001 -B
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0003,3003,0001,0000,2001,2002,2003
Boot0000* manjaro
Boot0001* Windows Boot Manager
Boot0002* ubuntu
Boot0003* ubuntu
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3002* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk

[cpossessky@cpossessky-pc ~]$ sudo efibootmgr -b 3002 -B
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0003,3003,0001,0000,2001,2002,2003
Boot0000* manjaro
Boot0001* Windows Boot Manager
Boot0002* ubuntu
Boot0003* ubuntu
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3003* Internal Hard Disk or Solid State Disk

[cpossessky@cpossessky-pc ~]$ sudo efibootmgr -b 3003 -B
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0003,0001,0000,2001,2002,2003
Boot0000* manjaro
Boot0001* Windows Boot Manager
Boot0002* ubuntu
Boot0003* ubuntu
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
[cpossessky@cpossessky-pc ~]$ sudo grub-install
Installing for x86_64-efi platform.
Installation finished. No error reported.

[cpossessky@cpossessky-pc ~]$ sudo update-grub
Generating grub configuration file …
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

[cpossessky@cpossessky-pc ~]$ sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

[cpossessky@cpossessky-pc ~]$ sudo efibootmgr -c -d /dev/sda -p 1 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”
efibootmgr: ** Warning ** : Boot0000 has same label manjaro
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0004,0000,0003,0001,2001,2002,2003
Boot0000* manjaro
Boot0001* Windows Boot Manager
Boot0002* ubuntu
Boot0003* ubuntu
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot0004* manjaro

[cpossessky@cpossessky-pc ~]$ efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0004,0000,0003,0001,2001,2002,2003
Boot0000* manjaro HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\manjaro\grubx64.efi)
Boot0001* Windows Boot Manager HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…/…
Boot0002* ubuntu HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\ubuntu\grubx64.efi)
Boot0003* ubuntu HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0004* manjaro HD(1,GPT,5e373847-3d45-4681-a83f-a14563aa6e68,0x800,0x82000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* USB Drive (UEFI) RC
Boot2002* Internal CD/DVD ROM Drive (UEFI) RC

I don’t know what is your current state. It looks like Manjaro should boot normaly.
Anyway get in an installation system prompt (TTY or terminal) run this to try make efi boot options visible

sudo efibootmgr -t 5

Hopefully you may get a list during next boot.

Okay, looks like you have one of those HP which won’t let you boot ‘non-compliant microsoft approved’ OS’s.

So let’s do this instead at manjaro terminal

sudo cp /boot/efi/EFI/ubuntu/grubx64.efi /boot/efi/EFI/grubx64.efi
sudo cp /boot/efi/EFI/ubuntu/shimx64.efi /boot/efi/EFI/shimx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/ubuntu/grubx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/ubuntu/shimx64.efi
sudo update-grub

Read here for more explanation.

Good luck.

Oh, each time you reboot, please provide

efibootmgr

Prior to Manjaro, I installed LinuxMint alongside Windows 10 which worked fine and I was able to use grub to switch between Windows and Linux Mint. After installing Manjaro, the problem arose.

Yes, I understand. Do you still have LinuxMint?
If you don’t have it anymore, you can do

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/ubuntu/grubx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/ubuntu/shimx64.efi
sudo update-grub

instead of the previous post
But you can still the previous post even if you don’t have LM.
So I was just careful.
Have you done it?

This is too frustrating. I want an OS I can install and go. I am giving up on Manjaro. Thank you so much for your time.

@CPoss This is sad. Microsoft’s dodgy business practices depend on people like you. :cry:

I understand your frustration. Some HP users here have opted to install in bios-legacy instead of uefi. If it is any consolation, IMO, Lenovo is worse, it is clear Lenovo is complicit while it can at most be argued that HP’s uefi implementation is ‘flaky’.

Wish you all the best. And good luck.

@grinner, I installed LinuxMint very easily. I’m going to try others, too. the reason I’m trying Linux is because Windows 10 is very slow and I can’t take it.

I hope you find a linux distro that suits. The point was that your frustration is caused by Microsoft. Some distro’s sign up with them. Good luck. :smiley: