Grub menu not shown when booting, instead Manjaro boots up

grub
dual-boot

#1

After a clean install I’m not getting grub menu option to choose other os, instead Manjaro boots up by default
I tried changing the time out but no luck.


#2

See here, the relevant part …


#3
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=84e06bdf-1941-42b8-b949-3d8579926157"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

this is my grub config


#4

Change this part

to this:

GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

and then:
sudo update-grub


#5

thank u for ur help…

sudo grub-editenv - unset menu_auto_hide

i think i’ll close this topic too…
Thank u, cheers


#6

How you do that ?


#7

:sweat_smile::sweat_smile:
By not responding :stuck_out_tongue_winking_eye:


#8

Good that you find your answer … As i don’t deal with silent-grub (or whatever), for me the editenv was not so obvious to deal with. I’ll mark your comment as solution.


#9

@bogdancovaciu
Your solution is okay but must do ‘grub-install’ and then do ‘update-grub’.
Best to clear out gubenv also - ‘rm /boot/grub/grubenv’

Cheers.