GRUB menu is not appearing on my Lenovo C3020 AIO desktop with Windows 10 dual boot

@megavolt. I have noted your point and removed bios-grub flag from the /dev/sda8 partition.
I have pasted screenshots of my BIOS (statup menu option) and gparted app (for partition flags) herewith for your quick view. Let me know if you need any other inputs. Thank you.

Adding a few more screenshots of BIOS with text against each option-


see there is one easy solution and one hard one easy one is that you format the whole drive into mbr partition skeheme the reason i am sayeing because mdr dosent need these efi partitions and other things you can directly install it
after you format the drive turn off uefi

@hisham_6c5 , I am staying away from full disk formating is because of the windows 10 partition. My kid is using this desktop for his school work and he has to use only Windows as per his school instructions.

Other option is to reinstall the windows, but I did not get OS license key information as it was pre-installed by Lenovo. I am afraid, i may mes up with my existing Windows installation and I may have to re-purchase OS license.


Thanks for posting these screenshots. That makes it clear why it does not work.

  1. Disable CSM (which means legacy or BIOS mode)
  2. Disable Quick Boot (which means full initialization without “pre-cached” configs.
  3. Boot Mode: UEFI only (disable BIOS mode completely)
  4. On “Primary Boot Sequence”, you should be able to put “Manjaro” at first place (on top).

Now Manjaro should boot. You should see the Grub bootloader and should be able to choose Windows there also.

As I see, both “Manjaro” and “Windows”, are installed in UEFI mode, but as you can see in the “Startup Device Menu” at “SATA1”, the “Windows Boot Manager” comes first and then “Manjaro”. This is the cause of all this trouble.

@megavolt thank you for your prompt support as always. I have followed your guidelines and after save and restart, I am getting an error saying “Invalid signature detected. Check secure boot policy in setup.”. I am pasting herewith screenshots of error message and few other BIOS options screenshots which I found may be relevant. BTW after doing these changes, I see Manjaro sitting on top of Windows in the start up device menu.

Not sure why is the system saying invalid signature. Kindly let me know if you need any further inputs on this context. thanks.


Manjaro does not support “Secure Boot” by default, thus you have to disable it. Maybe Windows was installed with “Secure Boot” enabled? I would disable it and try to boot both with the “startup device manager”. If Windows and Manjaro boots normal, then it can stay disabled.

However, “Secure Boot” is just a method for checking if the kernel, driver or boot files have the correct checksum or signature. It just checks if any program manipulate theses files (or installed a new kernel etc), so rather a nice security check on top, which is not really necessary.

Thanks a ton @megavolt . Finally I am able to see GRUB menu on boot. This last setting of turning off secure boot put and end to this issue.

i would like to take a moment to thank yourself and the other community members, who patiently listen to new guys in setting up their system and ensuring it works as expected. This selfless service is indeed exemplary. Guys like you make this place a better place to live. thank you.


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.