Grub menu doesn't show even after configuring it to

My Grub configuration file:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0 resume=UUID=ddc9e6e7-092b-46e3-868d-8b441a8711f6 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking
#GRUB_ROOT_FS_RO=true

ESC makes the screen black forever and SHIFT doesn’t work.

I am on linux515 and I have proprietary nvidia drivers installed.
Any idea why is this happening?

Update: Ok so I tried setting GRUB_TIMEOUT to a high value and it actually took longer for the system boot which means that Grub is there but it just doesn’t get displayed. I am assuming this is some kind of video driver issue. I am on Nvidia proprietary driver (video-nvidia-390xx).

You need to run update-grub as root.

I did that.

Then reboot and check the grub menu.

My guy, it doesn’t show up.

I think it’s the “saved” value.

Next time when you see any other thread from me, just click away please.

What do you mean?

RTFM

have a nice day

1 Like

This post was flagged by the community and is temporarily hidden.

change this to

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=show

Did that, updated grub but still it does not show up.

Try to remove GRUB_TIMEOUT_STYLE=menu, then sudo update-grub, then reboot if it works?

Can you post /boot/grub/grub.cfg ?

Try:

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu

Then sudo update-grub.

Reboot and enjoy.

I had the same issue Fully working grub on totally black screen after nvidia-340xx-dkms build and install

As a work-around, set
GRUB_TERMINAL_OUTPUT=console

and you get a small graphical output, not pretty but does the job.

spam ESCAPE and SHIFT key during boot to force show the menu.

Which kernels are installed ?
mhwd-kernel -li ?