Grub_key_is_interrupt

grub
amdgpu
installation

#1

Hi

I tried installing architecht and it “worked” for a few times, once I got to choosing DE it was two boxes with no names, instead of the usual list of DE. Anyway, after a few attempts I got :

error: symbol ‘grub_key_is_interrupt’ not found.
Entering rescue mode…
grub rescue>

I have tried several options in my BIOS (ASUS MB) which as selecting Secure boot > Other OS
Setup mode advanced /and easy
CSM all options on boot device control (UEFI and Legacy opROM, Legacy opROM only, UEFI only.
Set “Harddrive BBS Priorities” to the usb I use ( I have also used two different USB)

I used rufus to make a image and it prompted me too download Grub 2.03 and I’ve tried both 2.02 and 2.03.

When it worked I got this message :

[“no ums support in radeon module” error when trying to install manjaro, it doesnt stop the installation but for some reason non of the regular DE was there, and I didnt get asked to install drivers as usual for gpu.

So Q1,
What can I do too purge\remove\avoid > error: symbol ‘grub_key_is_interrupt’ not found. as it wont boot into install

And Q2
What doe # [“no ums support in radeon module” error mean?
I have Radeon HD6970 card which is an old one, but it should still work?’’

Edit 1 : I Have successfully installed Ubuntu 18.10 this only appears when Im using a manjaro usb


The symbol "grub...key...is...interrupted" is not found in the grub after the latest update
ISO Fix
Grub rescue - no such device - unknown filesystem after install
#2

For 1st question, create Live media with dd or Rufus in dd mode, or with Etcher.


#3

Actually solved both problems, thank you :slight_smile:


#4

Would you mind posting the solutions, so others will benefit, as well?


#5

I had the same problem - “grub-key-is-interrupt” message. Not sure what helped, but what I did was changing the partition type to ms-dos (previously had gpt). I’m also not sure if my boot partition wasn’t formatted as ext4 instead of ext2 - I changed this too. So after having done these 2 changes it started to boot correctly.


#6

Not sure… Maybe the message is the same but OP probably had not created a proper media.

This shouldn’t matter.
About the GPT/MBR, it could be, because when using UEFI on Legacy boot, GPT needs proper handling.
Nevertheless, since it works, all is good! :blush:


#7

Hello guys and sorry for my ignorance
Can you be more specific?
How can I create live media or dd mode?
for example with Rufus how can create live media or dd mode?


#8

If you are using Windows - you must use Rufus to write the ISO to an USB stick.

When starting the write process - Rufus will prompt you:

  • Use ISO mode (default)
  • Use DD

You must choose DD mode because otherwise the USB stick is not created correct.


#9

OK, what exactly was done. grub_key_is_interrupt got introduced with this patch and therefore got added with grub 2.03.0-10. Does a standard Manjaro v18.0 ISO release work?


#10

It’s this one? Oups…
Please, don’t shoot the messenger… :zipper_mouth_face:

Edit:
I looked up in the forum for this error and answered where needed.
It’s good to know what this error means (improperly created media), so we give a quick solution.
Thanks @philm ! :slightly_smiling_face:


split this topic #11

A post was split to a new topic: Grub corrupt


#12

In my case after writing image in DD mode as you said it booted properly and that solved the problem for me. Thumbs up :wink: