Grub is not working on boot

It didn’t change a thing. And I have indeed GRUB_TIMEOUT_STYLE=menu in the grub file

try tapping shift during boot… if it doesnt work, try tapping esc during boot

Tapping shift worked! It opened a Manjaro themed grub. I will see in the near future if it’s only when I tap shift, and if there are options I can change

Thank you!

(I don’t know how to close the topic)

did you also try with esc ?
post also output from:
cat /etc/default/grub
so that i can compare it to mine…

esc seems to work also. I must say that on one boot, grub appeared for 1 seconds, and it booted without me picking the boot options. I cannot say yet if it will be recurrent.

Output of cat /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash udev.log_priority=3 ibt=off"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Uncomment to disable submenus in boot menu

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:

do you have this first line there?:
so that it looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash udev.log_priority=3 ibt=off"

Yes, I have the same first line, I miss copied.

ok, try increasing the timeout from 5 to 10 seconds, change this line to look lik this:


save grub, update grub:
sudo update-grub

It seems to work without esc. I even increased to 15 (I saw the timer being quite low when the grub showed).

Thank you for your help. I won’t reply quickly anymore (end of my day).

so the grub menu now appears normally, without pressing shift or esc?

Yes it does

so the issue is solved then

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.