Grub falls in rescue mode repeatedly after Win10 update

Hi Manjaro-Community,

a few months ago I decided to create a Dual-Boot System with Manjaro and Win10 on my Notebook. So far I could manage all troubles I encountered on that way by myself, thanks to this forum and other resources on the internet. However since yesterday I face a problem which I could not manage to solve by myself so far unfortunally… let me explain:

Win10 decided to run an update. After the installation I tried to reboot and Grub falls into rescue mode. Ok so far nothing special, after a quick google search I found some tips on how to handle that problem. The most common solution seems to be this one:

ls

searching for the right partition…

set prefix=(hd0,gpt6)/boot/grub
set root=(hd0,gpt6)
insmod normal
normal

That worked pretty well. Grub started, I selected Manjaro. Everything went smoth.
Then update grub to save the new settings.

sudo update-grub

No error messages.

sudo reboot

But somehow it does not updates or saves the config. Grub keeps falling into rescue mode after starting.

I tried different approaches e.g. re-installing grub, use a LiveUSB and mount the partitions to update/re-install grub, tried boot-repair-disk on a bootable stick (“Please enable repository containing [grub-efi-amd64-signed] packages in the software sources of Manjaro Linux.”) Win10 seems not to be affected. If I change the boot-order, I can run it perfectly.

Nothing seems to work and I am running pout of ideas. What am I doing wrong? Is there somthing obvious I am missing? Secure-Boot is disabled, as well as Fast Start-Up. Btw I have a UEFI System.
I am glad for every helpful advice. Thanks in advance.

tinu

1 Like

You also need to grub-install

sudo grub-install /dev/sda

See this for more details.

ps: shouldn’t ‘(hd0,gtp6)’ be ‘(hd0,gpt6)’ ?

Thanks for your reply.

Of course, mixed it up while writing this post.

Had the same idea. Did it, made a update-grub, but it keeps starting in rescue mode whenever I reboot.

I read that when Windows makes an update, it creates an additional partition (for whatever reason) and thus the entries in the grub config-file are no longer correct, since the partition numbering got changed. But an re-installation and update-grub should fix that, right?

You can check that out with ‘sudo parted -l’, ‘lsblk -f’ or many other stuff. If that is the case, change your /etc/fstab, mount that different partition as /boot/efi (umount the old one first) and do grub-install and update-grub. There’s no need to reinstall.

But it would be unusual for windows to create a new partition for $esp as there is an existing $esp for it. The updates would at most ‘destroy’ all other things (linux things) in that $esp. Also, in your first post, you used the same partition (hd0,gpt6) to boot up. So I don’t get this.

Just provide the following (so we can follow you)

sudo parted -l
cat /etc/fstab
sudo blkid
cat /proc/cmdline

Sounds like a malicious update by our friends at Redmond?

Gives me:

Modell: Unbekannt (unknown)
Festplatte  /dev/nvme0n1:  512GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende   Größe   Dateisystem     Name                          Flags
 1      1049kB  473MB  472MB   ntfs            Basic data partition          versteckt, diag
 2      473MB   577MB  104MB   fat32           EFI system partition          boot, esp
 3      577MB   593MB  16.8MB                  Microsoft reserved partition  msftres
 4      593MB   374GB  374GB   ntfs            Basic data partition          msftdata
 5      374GB   375GB  528MB   ntfs                                          versteckt, diag
 6      375GB   396GB  21.5GB  ext4
 7      396GB   504GB  107GB   ext4
 8      504GB   512GB  8590MB  linux-swap(v1)


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
#UUID=7A3C-3A58                            /boot/efi      vfat    defaults,noatime 0 2
UUID=b4973293-753a-4b3e-8221-06ddcdaec015 /              ext4    defaults,noatime 0 1
UUID=da2358a0-60be-4e86-9cf7-702be0f0b841 /home          ext4    defaults,noatime 0 2
UUID=ee529e04-dd49-4bbd-b666-5583d70123f1 swap           swap    defaults,noatime 0 0
UUID=7A3C-3A58	/boot/efi	vfat	defaults	0	1
/dev/nvme0n1: PTUUID="ba541dc9-5315-42ed-bdae-12f582ea54fb" PTTYPE="gpt"
/dev/nvme0n1p1: LABEL="Wiederherstellung" UUID="08D03BECD03BDE9E" TYPE="ntfs" PARTLABEL="Basic data          partition" PARTUUID="4c19b7dd-7685-4fd5-a91a-9c95e7a878d1"
/dev/nvme0n1p2: UUID="7A3C-3A58" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="634cc974-  c8f4-46a7-84ea-8b6ac8988f63"
/dev/nvme0n1p3: PARTLABEL="Microsoft reserved partition" PARTUUID="cea8fce6-2bd7-4ec3-bbd5-07721de4cb88"
/dev/nvme0n1p4: UUID="7A50448E50445355" TYPE="ntfs" PARTLABEL="Basic data partition"   PARTUUID="ac5f4f88-41e9-40dc-ae5c-831c042f4ab9"
/dev/nvme0n1p5: UUID="54F64430F6441520" TYPE="ntfs" PARTUUID="48849890-a3b4-4eb2-bfac-3b05918bd2eb"
/dev/nvme0n1p6: UUID="b4973293-753a-4b3e-8221-06ddcdaec015" TYPE="ext4" PARTUUID="8e7ccf06-77a0-4382-a1d7-4faeea635cf8"
/dev/nvme0n1p7: UUID="da2358a0-60be-4e86-9cf7-702be0f0b841" TYPE="ext4" PARTUUID="bfe84f05-972b-438b-8d30-b72442c8cd0d"
/dev/nvme0n1p8: UUID="ee529e04-dd49-4bbd-b666-5583d70123f1" TYPE="swap" PARTUUID="abfd4d76-18a1-42fa-91e5-f9b2ca3cb53b"
BOOT_IMAGE=/boot/vmlinuz-4.9-x86_64 root=UUID=b4973293-753a-4b3e-8221-06ddcdaec015 rw quiet  resume=UUID=b4973293-753a-4b3e-8221-06ddcdaec015

I hope this provides some clarification.

Do you know why this line is commented out in fstab?
Try uncommenting and reboot.
Maybe, before reboot, mount

to /boot/efi and run update-grub and then reboot.

Still no change.

Also no change. It still starts in rescue mode.

Wie Gehts.
Please go through all the steps.
Boot up Manjaro.

  1. fstab
    Your original fstab is fine.
    If you have modified it as per petsum (which is fine) but just make sure you have only one entry for /boot/efi

  2. Check at terminal

findmnt /boot/efi

Make sure ’ /dev/nvme0n1p2 and UUID=7A3C-3A58’ and other stuff is listed.

  1. sudo grub-install

I am unsure you did this earlier. You did not make clear this was done. Whatever, even if done earlier, do again.

  1. sudo update-grub

It’s okay, do again.

  1. efibootmgr

Make sure manjaro entry is listed, and at top of the bootorder.

  1. Do this command.

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

You must do this command.

Reboot. Good luck.

2 Likes

This worked superb. Thank you very much!

But do you mind “teaching me how to fish”, apart from the last command in step 6., what you suggested seems not different from what I trief so far. Can you explain it to me please, so know how to handle troubles like this by myself in the future. I am curious.

Again, big Thanks for your help!

Edit: I guess we can mark this topic as solved.

2 Likes

Good to hear and you’re welcome.

You can use grub gnu website or you can access the same by typing in the terminal

info -f grub -n ‘Simple configuration’

exit by typing ‘q’.

Cheers.

@gohlip Is the man! :smiley:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark