Grub error while installing


I get an error on Grub while installing. Does anyone have an idea what I can do about it?

I already saw that there is a similar thread from october, but that didn’t help in my case.

I vaguely recall something similar. Something with the efivar fs not mounted. The solution was to mount efivarfs and mount the install partition and the corresponding /boot/efi partition and then chroot to the install system and manually running the

grub-install --target=x86_54-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force

The efivarfs must be mounted before chrooting into the new system for grub installation

Thank you for the quick reply. Sorry if the question is stupid but I have to do that after I got this error?

At the time I faced it this wiki was of great help

Even the grub-install fails you still have a complete system.

Open a terminal in the live enviroment

mount -t efivarfs efivarfs /sys/firmware/efi/efivars

mount your root partition on /mnt

sudo mount /dev/sdxY /mnt

mount your efi partition

sudo mount /dev/sdxZ /mnt/boot/efi

chroot into your mount

manjaro-chroot /mnt

In the chrooted environment

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force

I tried what you said. My laptop is just rebooting.

That didn’t work. It said it is already mounted.

Holy cow! I see it in my bios/efi.
But when I boot from it I just get


Ok, i ran an update-grub in the live environment and was able to get into the emergency console and updated the grub there again and now I can start my Windows from grub, but my Manjaro doesn’t boot and always gets me into the emergency console.

With journalctl -xb I got following error
emergency.service: Failed at step EXEC spawning /bin/plymouth: No such file or directory

Then you have removed plymouth without removing the reference to it in mkinitcpio.conf

Remove it and rebuild your init images

Refer this post for more details.

grub> search -f /boot/intel-ucode.img

Any output? write down what that is, ‘hd0,gptx’ and that is your installed Manjaro partition?
If yes, proceed.

grub> search.file /boot/intel-ucode.img root
grub> ls ($root)/boot/

copy down kernel and initramfs so it may be vmlinuz-4.9-x86_64 and initramfs-4.9-x86_64.img
Proceed with

grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.9-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.9-x86_64.img
grub> boot

Change to correct kernel/initramfs that you copied down.
When booted up to installed manjaro, do this first

sudo pacman-mirrors -g
sudo pacman -Syyu

Then check if there is a /boot/efi

findmnt /boot/efi

Then do

sudo grub-install
sudo update-grub

If you get error message as before on ‘plymouth’

Amend one line - the linux line above to

grub> linux /boot/vmlinuz-4.9-x86_64 root=UUID=$abc rw 3

Note the ‘3’ added.
If you can boot to prompt, login with password and then
sudo pacman-mirrors -g
sudo pacman -Syyu
sudo grub-install
sudo update-grub

Then fix your graphics.

Thank you for all the replys.
I was able to make it work with manjaro architect.
It took like forever but it is up and running :grin:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by