Grub error on load wont boot without USB in

I just installed Manjaro from a live USB and make a permanent install on a second USB (32GB)

All went ok, when I rebooted, the menu appeared for Windows or Manjaro, fine.
But them Manjaor was running extremely slow. Like molasses.

The, because I only wanted Windows to boot, I took the USB out, then rebooted.

Now a grub error comes up and a blinking dash and I cannot boot into Windows or anything at all.

I can only boot up to WIndows or Manjaro when the Manjaro USB is in the slot.
No USB, no boot.

I checked the boot order and it is orrect, it checks windows first.

Is there a way to fix this?


The specific error is:
error no such device
unknown file system
entering rescue mode
grub rescue>

So I ran ls, it showed
hd0, msdos1 and hd0,msdos2

I then ran ls (hd0, msdos1) but that returned:
hdo, msdos1 filesystem is unknown

Both 1 and 2 are unknown, this is a problem I think.

You have set mbr to the internal drive instead to the manjaro usb. So without the manjaro USB, nothing boots.

The other thing is that since you have wiped out windows boot from the internal, Windows boatloader is gone and needs to be installed back and manjaro boot to its usb.

However, as you found, manjaro is slow, installed at usb, it is much better to be installed at the internal drive. And if you do that, you will not need to reinstall windows boot.

Just make sure you install boot to the internal drive when you do that.

Thanks a lot for the direction. It's a start.

I let Manjaro do the instll so not idea why it changed MBR.
Do you mean "I have to set" mbr back to internal? Or I already set MBR to internal?

I do not have installl disks for Windows to put bootloader back. This is a problem.

So you're suggest installing Manjaro as on windows hard drive (along side Windows) then it will boot with both options?

Is there a way to remove Manjaro completely? This might be best but then again I would not be able to load windows.

I mean is the USB eventually going to give out and make the computer unable to load?

In your current condition, it is not wise to remove Manjaro yet.
Boot with USB to Manjaro and at Grub menu select windows. If it succeeds, try to repair boot (for and from windows), I don't know how, ask in Windows related forum.
If you can make windows boot normally without USB installed, repairing USB Manjaro can be done.
What is needed for external drive installations, is to install grub on the external drive, not on internal drive. You have to check proper drive descriptors before this.

You can right now boot manjaro and windows but with the Manjaro usb attached.
Just do 'update-grub' at manjaro terminal to get windows entry in it.

The reason for my suggestion is mainly that manjaro is "running extremely slow. Like molasses."
With manjaro installed at the internal disk, you will not find manjaro slow.

You will need to reinstall windows boot. But I cannot advise how to do it.

No.

OP has already set mbr to the internal disk. Setting mbr again to external usb will not solve the windows boot issue as the internal drive mbr is already occupied by manjaro.

I thought I wrote that and you have already agreed

:man_shrugging:

Oh.. okay. It can be done? Okay then.

1 Like

ok thanks to you both for trying to resolve this.

My knowledge is basic so bear with me:

So I load the molasses slow USB Manjaro permanent install, then at terminal write:
"update-grub". Correct?

For this you simply mean when the menu options appear for Manjaro or WIndows, select windows. I suppose that is the GRUB menu?

The only remedy for windows reinstall is to wipe clean the who disk. Ouch

yes

yes.

Who said that?

Thanks. Ill try now. WIll be slow.

I went into the computer safe mode and the only way to reinstall windows is to wipe the disk clean. The computer must have a safe partition where it stores defaults.
It is an option but don't want to do it.

Better ask help for this at a windows knowledge base/forum. I think it's possible to just repair boot, without re-installing.

ok so I did the update-grub command.
Same scenario - needs the usb. Is something else possible?

Correct. Now does that have windows entry?
Does that boot to windows?
That is exactly what we (AgentS) want you to do.

Hi
No, booting without the USB brings up the error messages:

Error; device not found." XXXX-XXXXXX-XXXX" .
Error: no such device.
Unknown file system
Enterting rescue mode
grub rescue >

Booting with the USB brings windows startup, then switches to grub menu:
Manjaro
Advanced
Windows 7

I also tried to restore an entry point from Sept 30, windows couldn't do it. Said unspecified problem occurred.

And I've search extensive for solution on
Error; device not found." XXXX-XXXXXX-XXXX" .
Error: no such device.
Unknown file system.

Can't seem to find it or they require Windows disk. hmmmm

With manjaro usb attached, boot up and at grub menu, go to grub prompt (grub> ) by pressing 'c'
Type each command below and press 'enter'
grub> insmod ntfs
grub> search -f /bootmgr

What is the output? Tell us.

If there is only one output, continue..
grub> search -f /bootmgr --set=root
grub> ntldr /bootmgr
grub> boot

Thanks.
I did do ls command which returned just hd0,msdos1 and hd0,msdos2.
Is that what you mean by one output? Can you clarify?

I try those commands (remember this is slow slow slow) and report back.

I just read that mnjaro installs its own bootloader, versus other distros that dont. Might be the issue too?

.....

Hi
Ok pls note that the boot goes to grub rescue>, not grub>

so when I entered the commands it states unknown commond.

So what I did I looked for that online and the suggest was use the 'set' command.

when I entered 'set', the results were:
cmd path=(hd0)
prefix (hd0)/boot/grub
root=hd0

but that was all in grub rescue>
How do get to grub> from grub rescue>
This is why the command "c" didn't work I believe.

Thanks
(hd0 is my hard drive I think)

Still true? If so..

Boot to windows and try to fix windows boot. AgentS says it can be done.
If not true, reinstall.

1 Like

Nothing changed, as I mentioned.
You command you provided was inoperable.
Do you know how to get out of grub rescue>
?

Forum kindly sponsored by Bytemark