GRUB Error after Timeshift Restore

I’m a very content Manjaro XFCE user and recently updated my OS to the latest rolling release, and running the 6.1 Kernal.

I started using Timeshift quite some time ago, but never had to use it. I got it in my head to test it out. I chose the previous daily backup and restored it. My machine rebooted, as expected, but now I get an error after supplying my decryption password at reboot.

‘grub_debug_malloc’ not found

When the error is thrown, I’m dropped into the GRUB emergency recovery shell.

If I hit F11 at boot I seem to be able to bypass GRUB, enter my decryption password, and Manjaro loads just fine. Needless to say, my confidence in Timeshift is not very high. I tried to sudo update-grub, but it didn’t work. Can someone offer some help, please?

Have you tried reinstalling GRUB?:

Frankly, I was hoping there might be an alternative solution. I’ll give it a try. Thank you!

I followed the instructions, but they don’t account for encrypted partitions. So I also tried to incorporate these instructions as well. No luck. Same error. Has anyone else experienced this?