GRUB does not see Windows Boot Manager

Hello! I installed Manjaro with Windows 10 on my pc, but Grub doesnt see Windows Boot Manager. Though, i can boot to windows manually. Setting DISABLE_OS_PROBER to false didnt help. I tried adding a grub entry manually, but it failed as well: When i tried to boot into added entry, i got an error message that Operating System was not detected.

Did you run sudo update-grub afterwards? If no then please do and if yes then see this guide on dual booting with windoze and see Search results for "grub" - Manjaro

Did you uncomment the line GRUB_DISABLE_OS_PROBER=false, and did you update-grub afterwards?

Yes, i did. There was prober logs

Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found memtest86+ image: /boot/memtest86+/memtest.bin

On the boot menu screen when you scroll down there is also an option called ‘detect EFI bootloaders’. have you tried that? You probably have to boot again into the Manjaro ISO to try this. I think it’s only in the iso version.

Hey, cant find anything related:

Is that Live ISO or machine boot?
Should look something like this (is from a bit older iso version). Maybe it was removed recently.

Live ISO

This was changed seems like. The option is not available anymore in the current ISO.
Can you post lsblk -f please to see your partiton setup

Hey! Sorry for late responce. I probably did a very dumb thing: When i installed manjaro, in boot menu there was multiple options with my USB:
A regular one, and UEFI. I chosed non-UEFI option. Right now i booted into LiveCD choosing the UEFI option; There is Detect EFI bootloaders button.

Try this option and see if it finds and adds windows. Other than that update-grub normally should work. Every hardware is a bit different.

Okay, what should do? Just press “Detect efi boot loaders”? It shows a list of those. Should oi choose one of them?

choose manjaro, boot and run sudo update-grub in terminal. Let’s see if it helps.
I am not sure about your setup since you said you did something like a non-UEFI installation, is it?

Yes, i probably did a non-UEFI installation accidently. I installed manjaro multiple times on this machine and never had problems like this.
I tried to choose /efi/Manjaro/grubx64.efi, but that didnt work. It says “no such partition exist” (grub rescue)

If Windows and Manjaro are not installed the same way (UEFI or MBR) then you can’t have Windows in Manjaro’s Grub.

Oh, i think that’s the case. Is this a reason that my windows disk is read-only too?

Is there any solutions except reinstall?

No, it’s because you didn’t read and follow basic steps explained in many threads on the forum, like the one linked above.

Disable Windows features

Do you plan on doing read/write on your Windows partition? Disable Windows options like

  • Fast Startup
  • Hybrid Sleep
1 Like

Okay, thanks. True, that’s my bad.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.