GRUB command line shown at boot is not the one I set

Hello, I'm on Manjaro GNOME stable.

Some days ago I installed bootsplash-systemd and bootsplash-theme-vendor, edited mkinitcpio.conf, /etc/default/grub, regenerated initramfs, updated grub and all went fine. After GRUB I could see the spinner (no vendor logo but afaik it's a normal behaviour) and not the boot messages.

Then I tried to build a custom bootsplash, did the whole procedure to set it, uninstalled bootsplash-theme-vendor and rebooted. No bootsplash was shown, instead I could see the boot messages. I tried to install another bootsplash theme from the official repos with no luck.

Now, after this long (sorry) premise, here's what I found:
Doing journalctl -b --no-tail the second line I find is:
Command line: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=152e483f-c43e-4af8-99ce-654a904db50d rw apparmor=1 security=apparmor udev.log_priority=3 bootsplash.bootfile=bootsplash-themes/vendor/bootsplash

These seem to be the arguments of GRUB_CMDLINE_LINUX_DEFAULT inside /etc/default/grub but opening that file that line is actually different. The last attempt I did I tried to set bootsplash-themes-gnome and in fact that line is:
GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor udev.log_priority=3 bootsplash.bootfile=bootsplash-themes/gnome/bootsplash"

I don't really understand what's happening here, I hope someone could help me.
Thanks in advance.

EDIT: It seems like sudo update-grub is not working as expected. While in GRUB if I press 'E' on Manjaro entry I see that GRUB passes the wrong arguments to the kernel. I can manually set them to whatever I want but I can't figure out how to make it persistent.

may be need this ...
grub-mkconfig -o /boot/grub/grub.cfg

Thanks for answering. I already tried that command with no luck. When I do sudo update-grub grub.cfg gets updated. Strange thing, if I change theme and update-grub I can see the new theme in grub.cfg but every change to GRUB_CMDLINE_LINUX_DEFAULTis ignored.

I also tried to edit grub.cfg (I know I shouldn't do it) to delete bootsplash.bootfile=bootsplash-themes/vendor/bootsplash and then update-grub and that line appears again even though in /etc/default/grub it's actually different.
I really don't understand what's going on here.

I see that boot/grub/grub.cfg is built from /etc/default/grub through some scripts in /etc/grub.d. I don't understand how they work and I never touched that directory but maybe something is broken here?
Here's the content of grub.d:

[robin@robin grub.d]$ ls -la
totale 92
drwxr-xr-x   5 root root  4096 23 mag 01.28 .
drwxr-xr-x 105 root root  4096 23 mag 11.41 ..
-rwxr-xr-x   1 root root  8871 22 gen 20.50 00_header
-rwxr-xr-x   1 root root   270 19 mag 13.20 01_grub-customizer_menu_color_helper
-rwxr-xr-x   1 root root   524 23 mag 01.28 10_linux_proxy
-rwxr-xr-x   1 root root   211 23 mag 01.28 40_custom_proxy
-rwxr-xr-x   1 root root 12505 22 gen 20.50 42_linux_xen
-rwxr-xr-x   1 root root   202 23 mag 01.28 43_os-prober_proxy
-rwxr-xr-x   1 root root   230 23 mag 01.28 44_custom_proxy
-rwxr-xr-x   1 root root   276 23 mag 01.28 46_custom_proxy
-rwxr-xr-x   1 root root   216 22 gen 20.50 47_custom
-rwxr-xr-x   1 root root  1219  9 nov  2018 60_memtest86+
drwxr-xr-x   4 root root  4096 19 mag 13.20 backup
drwxr-xr-x   2 root root  4096 19 mag 13.20 bin
drwxr-xr-x   2 root root  4096 23 mag 01.28 proxifiedScripts
-rw-r--r--   1 root root   483 22 gen 20.50 README
-rw-r--r--   1 root root   279 23 mag 01.28 .script_sources.txt

Here's the content of .script_sources.txt (thought it could be relevant):

"current_name";"default_name"
"proxifiedScripts/linux";"10_linux"
"42_linux_xen";"20_linux_xen"
"proxifiedScripts/os-prober";"30_os-prober"
"proxifiedScripts/custom";"40_custom"
"47_custom";"41_custom"
"01_grub-customizer_menu_color_helper";"6_grub-customizer_menu_color_helper"

Please let me know if there are any other relevant files or if I'm totally on the wrong path. Thanks in advance.

EDIT: here are my system info: Dump your inxi -Fxzc0 here and bookmark it

Forum kindly sponsored by