Grub cannot find Windows 10

grub
kde

#1

I had to reinstall Manjaro on my desktop (BTRFS decided to go crazy).

WIndows 10 is installed on a separate SSD. Windows 10 and Manjaro have separate /boot/efi partitions.

I can boot to Windows if I select windows bootloader in the bios. However, Grub does not find the Windows 10 /boot/efi partition (sudo update-grub does not show Windows 10 partition).

Any suggestions how I might be able to get Windows listed in Grub menu?


#2

Try this first.
In Manjaro, mount the windows partition.
Then update-grub again. See if it this time it grabs windows now.
ps: Your windows disk might be …er ‘asleep’ (not the right word, but anyway…)

Failing which, you can add manually a custom entry for windows…

menuentry "Windows  " {
  insmod part_gpt
  insmod ntfs
  set root='hdx,gpty'
  search --no-floppy --fs-uuid --set=xxxxxxxxxxxxxxx
  chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

Change to correct ‘hdx,gpty’ and uuid xxxxxxxxxxxxx

Create and put in to custom.cfg

sudo touch /boot/grub/grub.cfg
kdesu kate /boot/grub/custom.cfg

#3

Thank you gohlip!!! I knew you would come to my rescue when it comes to dealing with grub!!

I will try these options and report back.


#4

Further to add…

If you cannot mount this windows partition, that’s the reason why os-prober cannot pick up windows.
You have not disabled fastboot and hiberfile in windows.

See this forum link.

Meantime, you can mount it (as per the link) with

sudo mount -t ntfs-3g -o remove_hiberfile /dev/sda1 /isodevice

Replace sda1 with your actual windows partition.

Then do os-prober. If it picks up windows, do update-grub.

sudo os-prober
sudo update-grub

More to add (does not apply to you as you have all OS’s in uefi)

Grub in uefi will not be able to pick up (not to mention, boot) windows in bios-legacy.
Grub in bios-legacy will not be able to pick up (not to mention, boot) windows in uefi.
Nothing in modifying grub.cfg will be able to boot windows in above situations.


#5

The custom entry did the trick. Thank you for your help.


closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.