Grub_calloc not found and unable to boot from USB

I’ve been trying to fix this for 6 hours now, and it’s time to ask for help.

I rebuilt my PC today, adding new fans and an AIO. Tested a boot cycle and whatnot before finalizing the build. Went to boot and wham! It posted, prompted me with grub, then showed the post logo again but Manjaro never started. Disabled the post logo in BIOS, hoping to see any boot errors, but it booted fine. Re-enabled the post logo and failed to boot again. Reset the BIOS, now I’m prompted with a “grub rescue” stating that ‘grub_calloc’ cannot be found.

Google tells me I need to reinstall GRUB, which is fine, but I cannot boot into any live ISO. Tried three different sticks and many images, but they all fail at a line refering to something like “Listening RF Kill switch”. The Live ISO contains a “Detect EFI” feature, which shows my Manjaro install, but trying to boot it results in a black screen.

Luckily I duel boot and Windows boots fine. I’m sorry that I cannot provide an inxi output due to not having access to the system. But the main board is a Crosshair 7 Hero (WiFi) if that’s any help.

Can anybody suggest another ISO image I might try?

Maybe try to start it with this kernel parameter:


This will avoid using it. Should work, since it is only about unblocking wifi or bluetooth.

Thanks for the suggestion. Disabling bluetooth/wifi in the BIOS causes the boot to stall after the line

Listening on Load\Save RF Kill Switch Status

Enabling them and it stalls after

Started Load\Save RF Kill Switch Status

With the parameter


The “Listening On” line errors and a blinking cursor appears on the next line. In each instance, a hard reset is required.

I’ve discovered that the Ubuntu 20.04 image is able to boot to a live system. Though I haven’t yet figured out if I can fix GRUB from there. I’ve just booted back into windows in order to do more searching and download more ISOs.

Adding nomodeset to grub managed to force it past the previous hang, but this time “Simple Display Manager” failed to start. I however could switch to a tty and login. From there I reinstalled GRUB. But, the system is still not able to boot. Booting the EFI/GRUB partition results in:

symbol `grub_calloc` not found

and booting the Manjaro partition results in a black/(POST logo) screen. I’m at my witts end. Next step, reinstall the BIOS.

Limited success. Downgraded the BIOS and switched to the silent BIOS on the GPU. That at least allowed me to boot the latest KDE ISO. Reinstalled GRUB and mkinitcpio. Now my BIOS has a boot entry for Manjaro which can successfully boot. But, GRUB is completely broken with the same error. Unfortunately, downgrade grub contains only the 2.04 version.