Graphics problems in Libre Office


#1

HI All,

My libre office has become unusable because the UI is flashing between black and white every time I launch it.
Has anyone else seen this problem? No other apps are affected. Doesn’t matter if I use still or fresh…

[chris@manjaro ~]$ mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

         video-ati            2017.03.24                true            PCI

network-broadcom-wl 2015.12.13 true PCI

Warning: No installed USB configs!
[chris@manjaro ~]$ !492
inxi -Fxzc0
System: Host: manjaro Kernel: 4.9.51-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
Desktop: KDE Plasma 5.10.5 (Qt 5.9.1) Distro: Manjaro Linux
Machine: Device: desktop System: Dell product: XPS 8300 serial: N/A
Mobo: Dell model: 0Y2MRG v: A00 serial: N/A BIOS: Dell v: A05 date: 09/21/2011
CPU: Quad core Intel Core i7-2600 (-HT-MCP-) arch: Sandy Bridge rev.7 cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27149
clock speeds: max: 3800 MHz 1: 1925 MHz 2: 1997 MHz 3: 1993 MHz 4: 1872 MHz 5: 1986 MHz 6: 1804 MHz
7: 1740 MHz 8: 1959 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Turks GL [FirePro V4900] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.3 ) driver: radeon Resolution: 1920x1200@59.95hz
OpenGL: renderer: AMD TURKS (DRM 2.49.0 / 4.9.51-1-MANJARO, LLVM 5.0.0)
version: 3.3 Mesa 17.2.1 Direct Render: Yes
Audio: Card-1 Advanced Micro Devices [AMD/ATI] Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series]
driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.9.51-1-MANJARO
Network: Card-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter driver: wl bus-ID: 02:00.0
IF: wlp2s0 state: up mac:
Card-2: Broadcom Limited NetLink BCM57788 Gigabit Ethernet PCIe driver: tg3 bus-ID: 03:00.0
IF: enp3s0 state: down mac:
Drives: HDD Total Size: 3384.7GB (33.8% used)
ID-1: /dev/sdc model: WDC_WD20EZRZ size: 2000.4GB
ID-2: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
ID-3: /dev/sdb model: Samsung_SSD_850 size: 256.1GB
ID-4: /dev/sdd model: SAMSUNG_SSD_PM83 size: 128.0GB
Partition: ID-1: / size: 34G used: 9.2G (29%) fs: ext4 dev: /dev/sdb1
ID-2: /var size: 18G used: 2.7G (17%) fs: ext4 dev: /dev/sdb2
ID-3: /home size: 153G used: 22G (15%) fs: ext4 dev: /dev/sdb3
ID-4: /boot size: 239M used: 107M (49%) fs: ext4 dev: /dev/sdb4
ID-5: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sdd1
ID-6: swap-2 size: 6.29GB used: 0.74GB (12%) fs: swap dev: /dev/sda1
Sensors: System Temperatures: cpu: 33.0C mobo: N/A gpu: 33.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 284 Uptime: 11 days Memory: 8666.3/16034.6MB Init: systemd Gcc sys: 7.2.0
Client: Shell (bash 4.4.121) inxi: 2.3.40


#2

Can you post a little video of this issue?


#3

What’s a good tool for doing that?


#4

Your smartphone? Tablet?
Even OBS can record the screen.


#5

Hi;

From my libreOffice notes:

2016/12/17 - 12:49 - Had terrible flashing problems with latest versions. Was anti-aliasing. Turn it off in Tools, Options, View


#6

Disable OpenGL output. Those idiote have enabled them for many drivers without any testing…

in ~/.config/libreoffice/4/user/ there is a file registrymodifications.xcu with 2 options:

<item oor:path="/org.openoffice.Office.Common/VCL"><prop oor:name="ForceOpenGL" oor:op="fuse"><value>false</value></prop></item>
<item oor:path="/org.openoffice.Office.Common/VCL"><prop oor:name="UseOpenGL" oor:op="fuse"><value>false</value></prop></item>

set them both to “false” and now try to open libreoffice again. Lets hope this will help.


#7

Thanks all. I turned off antialiasing and OpenGL and it’s usable again. Many thanks


#8

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.