Graphics flickering/tearing on 20.2 after clean install, Intel i915 driver

Hey all, recently updated my computer running Manjaro 20.1.2 to the latest version(20.2), and I immediately began having problems with the graphics flickering/tearing. Never had this problem before, so I decided to try a clean install to see if it was an issue with the update process but unfortunately still the same issue. I tried to include a photo example or link but it’s not allowed apparently. Any help would be appreciated, thanks so much :grinning:

System -
Asrock J5005 motherboard
Intel 605 integrated graphics over HDMI
8gb ddr
Hisense 4k 50" TV

Output of inxi -Fza --no-host

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
  root=UUID=ce266562-5461-4f3f-b724-4cfe65166558 rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Console: tty 2 DM: LightDM 1.30.0 Distro: Manjaro Linux
  Type: Desktop Mobo: ASRock model: J5005-ITX serial: <filter>
  UEFI: American Megatrends v: L1.99 date: 01/21/2020
  Device-1: hidpp_battery_0
  model: Logitech Wireless Touch Keyboard K400 serial: <filter>
  charge: 50% (should be ignored) rechargeable: yes status: N/A
  Info: Quad Core model: Intel Pentium Silver J5005 bits: 64
  type: MCP arch: Goldmont Plus family: 6 model-id: 7A (122)
  stepping: 1 microcode: 34 L2 cache: 4 MiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 11984
  Speed: 1314 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 1314
  2: 2137 3: 799 4: 974
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user
  pointer sanitization
  Type: spectre_v2
  mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 605 vendor: ASRock driver: i915
  v: kernel bus ID: 00:02.0 chip ID: 8086:3184
  Display: server: 1.20.10 driver: intel unloaded: modesetting
  alternate: fbdev,vesa tty: 72x46
  Message: Advanced graphics data unavailable in console. Try -G
  Device-1: Intel Celeron/Pentium Silver Processor High Definition
  vendor: ASRock driver: snd_hda_intel v: kernel
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:0e.0
  chip ID: 8086:3198
  Sound Server: ALSA v: k5.9.16-1-MANJARO
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASRock driver: r8169 v: kernel port: e000 bus ID: 03:00.0
  chip ID: 10ec:8168
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 7.72 TiB used: 7.4 GiB (0.1%)
  SMART Message: Required tool smartctl not installed. Check
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
  model: WD80EDAZ-11TA3A0 size: 7.28 TiB block size:
  physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter>
  rev: 0A81
  ID-2: /dev/sdb maj-min: 8:16 vendor: PNY model: CS900 240GB SSD
  size: 223.57 GiB block size: physical: 512 B logical: 512 B
  speed: 6.0 Gb/s serial: <filter> rev: 0613
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk
  model: Ultra Fit size: 233.25 GiB block size: physical: 512 B
  logical: 512 B serial: <filter> rev: 1.00
  ID-1: / raw size: 223.27 GiB size: 218.77 GiB (97.98%)
  used: 7.4 GiB (3.4%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%)
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  Alert: No Swap data was found.
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 176 Uptime: 33m wakeups: 3 Memory: 7.43 GiB
  used: 1.09 GiB (14.7%) Init: systemd v: 247 Compilers: gcc: N/A
  Packages: pacman: 1120 lib: 367 flatpak: 0 Shell: Bash v: 5.1.0
  running in: tty 2 (SSH) inxi: 3.2.01
1 Like

Try adding in your xorg config file Option "TearFree" "true" in the ‘device’ secction.

Else you can try to install linux54 and see if that kernel is better. Also linux510 would be an option.

Switched to linux54, that has taken care of it! Thanks so much!! Just curious, does switching to a different kernel version have any implications on updates/upgrade down the road? Sorry if it’s a silly question but I’ve never had to do anything like this before it always just worked OOB.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.