reached after 23.44s .how can i solve this problem?

@cscs i remove snapd …but the speed seems not increased. By installing KDE version will the problem go away ?? or what should i do ?

Is it actually removed/disabled ? check your systemd-analyze again.
Changing DE’s wont help much … I already outlined the big services I would discard.

9.935s NetworkManager-wait-online.service
8.434s dev-sda1.device
7.173s systemd-journal-flush.service
4.088s apparmor.service
3.760s polkit.service
3.440s upower.service
2.959s udisks2.service
2.263s systemd-udevd.service
1.700s NetworkManager.service
1.698s colord.service
1.660s avahi-daemon.service
1.588s accounts-daemon.service
1.575s systemd-journald.service
1.545s systemd-logind.service
1.498s ufw.service
1.469s systemd-tmpfiles-clean.service
1.335s ModemManager.service
1.174s ldconfig.service
1.118s systemd-sysusers.service
1.002s org.cups.cupsd.service
977ms systemd-random-seed.service
857ms bluetooth.service
843ms tlp.service

[asif@PC ~]$ sudo systemd-analyze critical-chain
The time when unit became active or started is printed after the “@” character.
The time the unit took to start is printed after the “+” character. @21.049s
└─ @21.049s
└─ModemManager.service @19.712s +1.335s
└─polkit.service @15.949s +3.760s
└─ @15.931s
└─ @15.931s
└─org.cups.cupsd.socket @15.931s
└─ @15.856s
└─sys-fs-fuse-connections.mount @25.958s +11ms
└─systemd-modules-load.service @3.834s +822ms
└─systemd-journald.socket @3.698s
└─system.slice @3.589s
└─-.slice @3.589s

Disable and mask NetworkManager-wait-online.service

Sudo systemctl disable --now NetworkManager-wait-online.service

Sudo systemctl mask NetworkManager-wait-online.service

And disable ModemManager.service

Sudo systemctl disable --now ModemManager.service

It shows
bash: Sudo: command not found

It shouldnt be capitalized…

But you dont need it anyways:

systemctl disable --now NetworkManager-wait-online.service

(this will disable the service that waits for network connection before loading)

1 Like

Tnx for your help …It slightly increase the speed. I cause for other reason… Before opening window screen goes black and there is no welcome or loading page like windows is showing when the pc opens . What you thin about it?


Could you please provide me the output of udevadm info --attribute-walk -n /dev/sda1 | grep 'DRIVERS=="[^"]' , please?

Thank you!

Here is the output:


Now its time to sudo nano /etc/mkinitcpio.conf !

Then find the line starting by MODULES=" , and remove everything between the quotation marks and add ahci sd_mod ext4 in between of the quotation mark.

Then find the line starting with BINARIES=" and clear everything (or add fsck fsck.ext4 if you want to check the disk quickly at startup)

Now find the line starting with HOOKS=" and remove everything except base .

After that go completely to the bottom, and add COMPRESSION="cat"

Ctrl+S to save, Ctrl+X to leave.

You may then execute sudo mkinitcpio -P , sudo update-grub and reboot!

It should be 10 to 40% faster (results may vary)!

1 Like

There is no `MODULES=" " and BINARIES=" " in the file

vim:set ft=sh


The following modules are loaded before any boot hooks are

run. Advanced users may wish to specify all system modules

in this array. For instance:

MODULES=(piix ide_disk reiserfs)

MODULES=“ahci sd_mod ext4”


This setting includes any additional binaries a given user may

wish into the CPIO image. This is run last, so it may be used to

override the actual binaries included by a given hook

BINARIES are dependency parsed, so you may safely ignore libraries



This setting is similar to BINARIES above, however, files are added

as-is and are not parsed in any way. This is useful for config files.


Please use the content in parenthese, thank you!

The layout may depend on your shell!


Please read carefully the instructions, thank you!

May add missing lines!

Thank you so much .Brother.
the screen show /dev/sda1:clean(more…) blocks
now the result is…
artup finished in 4.008s (kernel) + 22.638s (userspace) = 26.646s reached after 17.958s in userspace

Tnx everyone …

1 Like

You’re very welcome ! :innocent:

1 Like

Dont forget to get rid of ModemManager too, if you dont need to handle 3/4g connections and stuff:

systemctl disable --now ModemManager

(should save you another second or so :wink:)

1 Like

i have already get rid of it… Despite the screen is on the icons are coming late… is there any solution. I am new in linux… Suggest something from where i can learn the basics.
Again tnx for everyone for the efforts


So sweet!:relieved::candy:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.