Graphical glitches / artifacts after update to XFCE 4.14

Since the update to latest XFCE version I have very weird graphical glitches on my display (does also happen on second monitor when plugged in to HDMI port). These glitches do appear only when the laptop is not idling, i.e. me moving the mouse or typing. When keeping the laptop idle for a few seconds they vanish suddenly (they do not appear on screenshots). Everything worked fine previously. I'm using an AMD Ryzen 5 2500U CPU with integrated graphics Vega 8 which might play a role for this issue.

What I've tried so far:

  • Downgraded the packages: linux52 (to 5.2.4) and all mesa related packages (to 19.1.3)
  • Booted via LiveISO everything was fine -> no hardware problem

So I guess it must be XFCE related, is there some easy way to downgrade all XFCE packages at once? Does anyone else experience similar glitches?

Apparently there's an issue with the compositor.
Try turning it off and see if the glitches go away. If so, then you poor Xfce users will have to wait for them to fix it. :slightly_frowning_face:

1 Like

So, this is a known problem? I couldn't find it anywhere, can you link me to the compositor bug?

There's been several posts on the forums with people mentioning it.
But, I've been meaning to see if there's a bug report to Xfce. I'll see if I can track that down.

It's virtually impossible for me to do much on the forums right now as they are lagging bad for me.

If I find the bug report I'll post it. Maybe someone else will chime in as well.

1 Like
1 Like

Thanks @xircon. Having a helluva time today. Bad forum! Bad!


мигать мигать мигать

키보드가 고장난 것 같아

1 Like

To be fair .. xfwm's compositor has always been a problem.
The first thing to do in xfce is turn it off (and replace with compton if you want a compositor).
Its just sad because it was supposed to be better now.

Who knows .. maybe it is better for everyone except amdgpu ?
If so it might just be a little bug to be ironed out.
The testing is yet small :woman_shrugging:

I went through their bugzilla but didn't find anything.
That doesn't really mean much though. :woman_shrugging:

Seems to be an issue with amdgpu. Mostly compositing is tested on intel and nvidia.

Please try booting the 5.2 kernel with these parameters added: iommu=pt.
That has worked for others.

If it does work/fixes it, add it to the GRUB_CMDLINE_LINUX_DEFAULT= line in /etc/default/grub.
Save it and run sudo update-grub and reboot.

1 Like

I just forwarded this issue directly to XFCE.
Maybe we'll be helped there :slight_smile:

I've found a solution that solved my problems:

xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "xpresent" --create

, then restart xfwm.

Now I've only got to struggle with slight tearing issues while rendering :sweat: - but that's an other discussion.

1 Like

This has nothing to do with the problem. I'm using this option since the beginning so I can boot the system.

It did for me, and I'm on a 2700U.
I had graphical artifacts when I was booting 5.2 which I didn't have in 5.1. So it could have been that for you to.
I just know, it fixed it for me.

1 Like

Thanks, this is working for me too. Disabling the compositor is also possible as a workaround.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by