Graphical artifacts after latest update

See screenshot: There are thousands of tiny transparent yellow rectangles on the screen. They are in all the window titlebars all the time (as with the screenshot window in the screenshot) and they are in larger parts of some, but not all windows.

  • It is apparently a software problem and not a hardware problem as a) it occurred after an upgrade and b) it is visible in the screenshots.

  • The problem first occurred after a system software upgrade I installed (I think) on Jan 4th 2020.

  • The artifacts only occur in some windows. For example, they do not occur in the Firefox window or titlebar, but they do occur in the VS Code window and titlebar (both with native [KDE] and custom [I thinks it's GTK] titlebar style).

  • They flicker and change patterns on typing something within the window.

  • They do not scroll with the content of the window.

  • The problem appears both in the 5.4.6 LTS and in the 4.19.9 LTS kernel.

I have no idea about computer graphics and graphics drivers; I just know that everything worked fine and out of the box until that software upgrade.

I appreciate any help for further diagnosis and resolution :slight_smile:

inxi -Fx
System:    Host: david-pc Kernel: 4.19.91-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Swift SF114-32 v: V1.09 serial: <root required> 
           Mobo: GLK model: Sapporo_GL v: V1.09 serial: <root required> UEFI: Insyde v: 1.09 date: 04/03/2019 
Battery:   ID-1: BAT0 charge: 52.5 Wh condition: 52.5/54.2 Wh (97%) model: PANASONIC AP15O5L status: Not charging 
CPU:       Topology: Quad Core model: Intel Pentium Silver N5000 bits: 64 type: MCP arch: Goldmont Plus rev: 1 
           L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8755 
           Speed: 783 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 796 2: 796 3: 796 4: 796 
Graphics:  Device-1: Intel UHD Graphics 605 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.6 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 605 (Geminilake) v: 4.6 Mesa 19.3.1 direct render: Yes 
Audio:     Device-1: Intel vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:0e.0 
           Sound Server: ALSA v: k4.19.91-1-MANJARO 
Network:   Device-1: Intel driver: iwlwifi v: kernel port: 2000 bus ID: 00:0c.0 
           IF: wlp0s12f0 state: up mac: 5c:87:9c:64:6f:f4 
Drives:    Local Storage: total: 238.47 GiB used: 41.39 GiB (17.4%) 
           ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3256GJ1 size: 238.47 GiB 
Partition: ID-1: / size: 224.78 GiB used: 40.89 GiB (18.2%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 8.80 GiB used: 512.8 MiB (5.7%) fs: swap dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 177 Uptime: 1h 01m Memory: 7.60 GiB used: 1.96 GiB (25.7%) Init: systemd Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 inxi: 3.0.37

Maybe it's the theme, have you tried a different one?

You could try uninstalling the intel video driver and use modesetting instead:

sudo pacman -R xf86-video-intel

Just tried using a different Global Theme, Plasma Theme, Application Style, Window Decoration; didn't help.

After setting AccelMethod to uxa (as explained in https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues ), the issue seems no longer to occur inside of windows, but only in title bars and other GUI elements.

I have now uninstalled the Intel Video driver.
(When I first tried, there was no GUI at all. I then realized that I had created a configuration file /etc/X11/xorg.conf.d/20-intel.confto set the AccelMethod (see above) and that the Intel driver was specified inside. So I removed the configuration file, uninstalled the Intel driver again, and the GUI is still working.; I suppose, with the modesetting driver.)
But the yellow rectangles artifacts in the window frames, at the desktop, and in some dialogs are still there.

I tried booting from some up-to-date live boot media of Manjaro KDE, and the artifacts show up there, too. This had not been the case with older live boot media (~1.5 months old).

The artifacts also show up all over some custom Java applications which I have to work with, even with AccelMethod set to uxa (see above).

Perplexing.

Have you tried changing the compositor's rendering backend or disabling compositing altogether? That's all under Plasma Settings > Hardware > Display and Monitor > Compositor. That's one of the first things I check when I get odd rendering issues.

Since you've already tried multiple kernels and drivers with no luck, have you tried using an up-to-date Gnome or XFCE ISO to see if this may be a Plasma or QT bug?

I have tried all settings in the compositor (XRender, OpenGL 2.0, OpenGL 3.1), without any change.

I have now also booted from Live Media with Manjaro Gnome / XFCE and even with Ubuntu Desktop, and the artifacts do also occur there, so it does not appear to be a Plasma or QT bug.

The strange thing is that I also tried booting from some Manjaro KDE live boot media from the end of 2019 (from before the artifacts first occurred), but the artifacts came up anyways. I can't really make sense of that.

If I only knew at what level these artifacts do probably occur, that would already be of great help to further search for solutions. Any ideas?

switch to testing branch and try the latest 4.19 LTS kernel. philm has backported i915 fixes to it from kernel 5.5

they might address your corruption issue too, so it is worth a shot. But as always you should use Timeshift to take a snapshot before applying any update so you can roll it back.

Check your region's mirrors have been updated before proceeding though, as the changes were only pushed a few hours ago. repo.manjaro.org

sudo pacman-mirrors --api -B testing
sudo pacman -Syyu

Thanks very much for the suggestion! I have switched to testing, updated and rebooted, but unfortunately there is no improvement so far.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by