GPU (R9 380) crashes and problems

Was struggling with this problem System frequently crashing after GPU drivers update before buying a new GPU from a friend (r9 380 Tonga) and installing it, now system is having crashes and GPU timeouts, freezing the whole system and requiring a hard system reboot. Now it’s also having these issues
Jul 21 21:39:38 desktop kernel: amdgpu: last message was failed ret is 0
Jul 21 21:39:42 desktop kernel: amdgpu: failed to send message 171 ret is 0

without the system crashing but anything related to the GPU (ie inxi, radeon-profile) will hang or crash.
Journalctl of a crash: Jul 21 02:29:06 desktop audit[24561]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses -
Tried installing amdgpu-pro drivers from the AUR with the Add/Remove Programs GUI but it hasn’t changed anything


               Distro: Manjaro Linux base: Arch Linux 
    Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME B450-PLUS v: Rev X.0x serial: <superuser required> 
               UEFI: American Megatrends v: 2008 date: 12/06/2019 
    CPU:       Info: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP arch: Zen rev: 1 cache: 
               L2: 2 MiB 
               flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 59118 
               Speed: 1856 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 1: 1856 2: 3993 3: 1631 4: 1627 5: 2043 
               6: 3642 7: 1627 8: 1627 
    Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Tonga PRO [Radeon R9 285/380] vendor: PC Partner Limited driver: amdgpu 
               v: kernel bus-ID: 01:00.0 
               Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1: 1920x1080~60Hz 
               2: 1920x1080~60Hz 
               OpenGL: renderer: AMD Radeon R9 380 Series (TONGA DRM 3.41.0 5.13.1-3-MANJARO LLVM 12.0.0) v: 4.6 Mesa 21.1.4 
               direct render: Yes 
    Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK PRIME B450M-A driver: r8169 
               v: kernel port: e000 bus-ID: 04:00.0 
               IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: 04:d4:c4:ab:93:bf 
               IF-ID-1: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
    Drives:    Local Storage: total: 2.73 TiB used: 270.16 GiB (9.7%) 
    Info:      Processes: 403 Uptime: 1h 11m Memory: 31.29 GiB used: 7.92 GiB (25.3%) Init: systemd Compilers: gcc: 11.1.0 
               clang: 12.0.1 Packages: 1852 Shell: Bash v: 5.1.8 inxi: 3.3.05 

your code tag insert system is terrible

Not the full output btw, it got cut off.

Also, likely unrelated to your issue but you should update your BIOS: PRIME B450-PLUS|Motherboards|ASUS USA

Don’t bother.

what specific inxi arguments do i need to pass

Don’t bother.

I tried installing them because trying to open War Thunder on this card caused a horrifying complete crash with total screen freeze with the game menu open but empty with pink and blue space invaders/game of life style pixels all over the two screens, and i mean all over the screens not just in the game, so yeah