GPT und Legacy boot mode *SORRY*

Dear Community,

It looks like I missed a couple of years: All Linux Distros that I am trying out insist on creating a /boot/efi partition. That is Zorin, Feren and PopOS.
I have very old hardware that works fine (see screens attached) and I wonder if my system supports GPT at all. I use legacy. Grub2 in MBR (Manjaro and MINT xfce installation 1 year ago both worked fine.

I tried to gdisk a partition table. Seemed to work - but in my boot options it looks like both of my (less tan 1 TB) disks are listed only in legacy mode?

any quick hints what I should do? Please, I would appreciate it a lot. :blush:

BIOS update? Oder wie?

Antworten gerne DE oder EN.

Thanks and have a good weekend


To be more concise with my questions:

*Why is it that picture two (my screens) doesn’t list any hdd in uefi mode?

*Next, I am doing multi boot alongside Win10 ameliorated btw if you know what that is, plus I want to try out several distros, such as Feren, Endeavour and PopOS and install them all along next to the other.

UPDATE: OK… sorry guys. It was all so easy!:
I boot my USB in legacy mode: no problem. The installer gives me the options that I am used to… (withoud EFI Partition)

(solved: Why is it that none of the above gives me the option to install into the MBR?)
Thanks so far,


BIOS Update ist gar keine schlechte Idee. Da gibt es ein ganz neues von diesem Jahr.
Intel ME Firmware kannst du da auch gleich mit aktualisieren.
Ich staune wie HP das Teil pflegt, könnte man neidisch werden.

Wird dir aber zu deinem Problem nicht helfen.
Wenn ich Bild 2 richtig deute ist dein System ein Hybrid.
Du hast Legacy und UEFI eingeschaltet.
Besser Legacy ODER UEFI !
Du schreibst ja selber das deine Festplatten MBR haben, also sind die Legacy Bios.
Bei UEFI hätten die eine UEFI Bootpartition.
Mein Tipp: schalte UEFI ab, ansonsten musst du alles neu machen oder umwandeln.
Durch das Hybrid weiß natürlich Linux nicht was es machen soll.

Da sind noch mehr drüber gestolpert.