Gnupg stopped working with latest major manjaro update - "end of file" related errors

Since the last major manjaro update gnupg stopped working as expecetd. It seems that any operation fails that requires the use of a private key - I tried decrypting, expiring a key as well as exporting the private key. The error that I get is always along the lines of " failed: end of file".

At first I thought that maybe some file in my .gnupg folder was corrupted. However, when I move my .gnupg folder to a computer with gnupg 2.1.18 all the operations cited above work as expected. When I copy a .gnupg folder that works on this respective computer to my manjaro machine, it does not work anymore.

To me it looks like it is related to the gnupg installation on my machine. Since I could not find any complaints about similar issues by others, I assume that it’s not a systematic problem but something related to my particular installation.

I already tried to reinstall gnupg including removing the cached installation package from my computer to force pacman to redownload it from the repositories. This did not solve the problem. Now I’m running out of ideas how to further tackle that problem.

If anyone has some hints what to try or how to proceed to further isolate the problem, I would be really grateful.

Thanks a lot.

And on the non working install, what does:
pacman -Qi gnupg
shows from terminal ?

If you downgrade, can you chose a different version and does work with it?
sudo downgrade gnupg

Output of pacman -Qi gnupg

Name                     : gnupg
Version                  : 2.2.23-1
Beschreibung             : Complete and free implementation of the OpenPGP standard
Architektur              : x86_64
URL                      : https://www.gnupg.org/
Lizenzen                 : GPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : npth  libgpg-error  libgcrypt  libksba  libassuan
                       pinentry  bzip2  readline  libreadline.so=8-64  gnutls
                       sqlite  zlib  glibc
Optionale Abhängigkeiten : libldap: gpg2keys_ldap [Installiert]
                       libusb-compat: scdaemon [Installiert]
                       pcsclite: scdaemon
Benötigt von             : gpgme
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 10,03 MiB
Packer                   : Levente Polyak <anthraxx@archlinux.org>
Erstellt am              : Do 03 Sep 2020 19:34:00 CEST
Installiert am           : Sa 14 Nov 2020 21:05:50 CET
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Ja
Verifiziert durch        : Signatur

I was able to downgrade to 2.2.21, however, this does not fix the issue.

I did some further investigation and came across another issue that might be related, but I’m nt sure:

  1. I took a look into the pacman log in /var/log/pacman.log. There I found that gnupg had been last updated in September, while the issues started with the upgrades I installed around November 10th. Hence I looked whether some of the dependencies listed in the pacman -Qi gnupg output had been part of this update run. The only dependency package that met this criterion was libgcrypt and I tried downgrading it to the version before the upgrade – unfortunately without any improvement.

  2. Since the upgrade Firefox closes itself whenever I click any link that would result in downloading a file from a website. When I start firefox from the command line, the final console output before the closing are

    (/usr/lib/firefox/firefox:45217): GLib-GObject-WARNING **: 22:05:50.041: invalid (NULL) pointer instance
    (/usr/lib/firefox/firefox:45217): GLib-GObject-CRITICAL **: 22:05:50.041: g_signal_connect_data: assertion ‘G_TYPE_CHECK_INSTANCE (instance)’ failed
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.
    Exiting due to channel error.

Maybe as a side note: I remember, that the upgrade was interrupted due to my root partition running out of free space. Could that somehow have had an influence if yes, how to check? And is there maybe a possibility to rollback the whole installation to the state before the upgrade?