Gnucash fails to update (‘cairo<=1.14.8’ required by gnucash)


running manajro xfce, totay received an update for gnucash. Was unable to update, got the following message:

could no satisfy dependencies:
unable to satisfy dependency ‘cairo<=1.14.8’ required by gnucash

Presently I have cairo 1.15.8-2 installed?


This means that to install gnucash, one needs to have cairo version 1.14.8 or below. And why is that you ask?

Solutions? Downgrade cairo to 1.14.8 for now

(Also I moved this to #technical-issues-and-assistance:aur , because gnucash is an aur package)

Gnucash - latest update - missing

thanks thefallenrat, I tried it but only got:
Available packages:

  1. cairo-1.15.8-2-x86_64.pkg.tar.xz (local)
  2. cairo-1.14.10-1-x86_64.pkg.tar.xz (local)

Those are newer than cairo 1.14.8


Try this :

sudo pacman -U$(uname -m).pkg.tar.xz


Thank This did the job.


I made the Cairo change and got gnucash to update from AUR. Now Octopi wants to update Cairo. Will this break gnucash? What happens on the next Manjaro update which I assume will occur in a few days?


Yes, as evidenced in my previous posts

Don’t update cairo if you want to still keep using gnucash

Also be wary that AUR is not officially supported by manjaro


Ok. I’m relatively new to manjaro and only use AUR for a few things like gnucash. I guess the old version of cairo is needed just during the build process. As an experiment, after building gnucash with the old cairo, I updated cairo with octopi and gnucash seems to run normally. So it appears that I need to watch out for further gnucash updates until they introduce their next full version which seems to be a ways off in the future. Thanks for you assisstance.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.