Gnome will not start after update. Gnome shell coredump found in journalctl.

gnome
update
xfce
#1

Hello all! I just attempted the 3/29 stable update, and it ended in gnome shell crashing. The login screen will show up, but after logging in, iam sent back to the login screen after a few seconds. I have heard this may be a fault of some pesky extensions. How do I know which extensions are causing this, and what to disable after I do a TS restore, and try again?

#2

I think you do not need to restore via timeshift. You can disable all extensions from tty see:


You than can try out which do work. Also see this:

1 Like
#3

Tracker-store is now coredumping, but somehow I just got gnome to start. I think I manually removed the “extensions” extension.

#4

It seems as though many things changed in this update, and I might be better off just waiting on this one as very few extensions will run on 3.32 at this point…

#5

NO all the useful extentions are up to date just do what @kdemeoz suggested it will be fine.

#6

Alright. Trying the update one more time

#7

Thanks everyone! It worked, but the manjaro updater now has no icon… how can I fix this?

#8

Ensure you have Enabled the Pamac Updater in Tweaks - Extensions.

#9

Yes. I can click on it, and it says system is up to date, but there is no icon.

#10

How strange! I shall defer to the many proper Gnomers here [me being a total amateur with it] who i hope might be able to help you. For me, my cute little red icon works well in the SysTray, & it has a fabulous dropdown list of the individual packages to update… i like this even better than how it works in Plasma. Good luck!

#11

What extension are you using? I might as well test it!

#12

just came across this thread that seems to be the same issue, depending on what icon pack you use

Update icon in panel gone
#13

Sorry, i might be misunderstanding you… but in the Stable Update thread i posted a picture showing all my current Extensions. Does that help at all?

#14

Screenshot%20from%202019-03-31%2021-32-33

#15

20190401_001

Given mine is not 100% GNOME, but 50% GNOME & 50% KDE, maybe my G SysTray Pamac icon is better-behaved than yours as some kind of legacy interaction with KDE? Dunno, just guessing.

OT - just saw a bug. See the pic’s date & time? Wrong; it’s actually 13:16 on 1 April here. Hmmmmm.

#16

it’s not playing nice with certain icon themes

1 Like
#17

OK ta.

Hahaha this is too funny. Note in my pic above, there’s 10 updates [Unstable VM]. I’ve now done them & rebooted, then tried twice to login to G. However…

If this was my real OS rather than just a play-thing, i’d probably not be laughing so much.


EDIT: Now fixed; it was a mesa bug… Mesa 19.0.1-0.2 issues

1 Like
Mesa 19.0.1-0.2 issues
#18

check the dip gyro and the flux capacitor extensions :joy:

2 Likes
#19

Will do, but what’s your opinion on me crossing the streams?

1 Like
#20

no no, one must never do that. :face_with_raised_eyebrow:

1 Like