Gnome white screen : "Oh no! Something has gone wrong." after updates

Hello there!

I am not an expert in all things too technical, that is why I post on the Newbie Corner. Yesterday, I wanted to install a new feature using AUR on my Manjaro partition. Since it had to do some other update I decided to let it do the updates first. However, it encountered some problems (if I recall correctly) linked to pacman mirrors. The error was something like: failed retrieving file 'core.db' from mirror.catn.com. As my work day was over I decided to look into that problem today.

However, this morning, as I tried to do those updates again, the computer crashed and I got a Gnome white screen with a message as in the title: "Oh no! Something has gone wrong." and a prompt to log out of my session. I did so and the same message appeared with a subtitle " A problem has occurred and the system can't recover. Please contact a system administrator. I could not log in again and thus not access my desktop.

I quickly took a look online, and I decided to use the tty terminal to access Manjaro and to do the update again. I logged myself in, did a pacman -Syyu, and it did the same errors as the day before that is with the mirrors. A look online gave me a fix and the update finished with quote "nothing to do". However, the problem of the white screen persisted.

As suggested on here I decided to take a look at the logs with journalctl more specifically journalctl -p4, which gave me the following output some errors like:

systemd[1514]: gnome-shell-x11.service: Main process exited, code=dumped, status=5/TRAP
systemd[1514]: gnome-shell-x11.service: Failed with result 'core-dump'
systemd[1514]: Failed to start GNOME Shell on X11.
systemd[1514]: Dependency failed for GNOME Shell on X11.
systemd[1514]: Dependency failed for GNOME X11 Session.
systemd[1514]: Dependency failed for GNOME X11 Session (session: gnome).
systemd[1514]: gnome-shell-x11.service: Failed with result 'exit-code'.
...
systemd-coredump[4301]: Process 1601 (gnome-shell) of user 1000 dumped core.
...

and later it output the same first 7 lines followed then by :

gnome-shell[4488]: clutter_input_device_get_device_type: assertion 'CLUTTER_IS_INPUT_DEVICE (device)' failed

followed again by a coredump.

Also tried to check the hardware with dmesg, but it didn't give any errors.

It is also suggested on here when asking a question to provide inxi -Fxxxza --no-host, so here you go (sorry for the fact that is a picture of my screen but as I do not have access to a desktop this was the best I could do...) :

Does someone have an idea what the problem is and why I cannot access my desktop ? How can I fix the issue ?

I am sorry if there were any English mistakes, it is only my second language. Also sorry again for the pictures.

Thanks in advance.

try

sudo pacman -S manjaro-gdm-theme

and

systemctl enable gdm.service --force

That does not seem to work. The first one installs what it should correctly and the second one activates the gdm.service correctly but when rebooting I still encounter the white screen.

What should it have done?

the first is gdm (which is the login window) second is to activate it.

I see gnome-shell dependency error

try

sudo pacman -S gnome-shell

to reinstall it if it will take something what is missing if it does not help I am out, you will need to wait for Manjaro advanced user. :thinking:

This seemed to do the trick ! The UI is now a bit different though, is that normal/ does it have to do with manjaro-gdm-theme ?

So could you login?
gdm is necessary and manjaro-gdm is standard packages in Manjaro ISO installation.
Yes it looks slightly differently then on Gnome 3.34

Yes I could log in thank you very much !!
Ok, is it possible to go back or will it bring me back to the same problem ?

Of course it is possible but I would not do it :slight_smile: You see this gdm only a fraction of time...
Why would you want to remove it? It is possible gnome 3.36 new look manjaro just added its own look I think.

Yes you're right ^^ Thanks and have a good day :wave:

1 Like

If you do not mind you can mark my solution as solution I will receive a point from Manjaro forum :slight_smile:

Forum kindly sponsored by