Gnome-terminal wont open after update

Hi guys this is my very first Topic on the internet
so today I update my packages and after that my gnome-terminal won’t open!!!
is not opening at all, I reboot the system even shutdown it but nothing has changed!
please help me, what should i do ?


Hi and welcome to the forum :wave:

You probably need to set your language again the the Manjaro settings manager, see :point_down: announcement. If you are having trouble please report what kind so we can help you further

You should follow this.
Install one terminal for temporary use from add-or-remove software.
(i used vscode terminal since i had initially)

  1. Run: gedit /etc/locale.gen and uncomment en_US.UTF-8 UTF-8
  2. Run: sudo locale-gen
  3. That’s it ! You should be able to open gnome-terminal now.

Please search before posting, there are already plenty of threads about this.


Having the exact same issue here as well but checking /etc I only see a file locale.conf - no locale.gen

Is this the same file?

this is the content of the file locale.conf


Solution from the release announcement:

  • Go to Manjaro Settings,
  • Add your language back in the regional settings,
  • Log off / log in

But check out the link Yochanan posted for more info about locale and what manual steps you can take.


Thanks a lot, its work on me

I did the same thing you said but it didn’t work!!! still not opening
I set up all my things in vscode terminal, and uncomment en_US.UTF-8 UTF-8
I don’t know what should I do, maybe i should delete Manjaro and reinstall it again.
oh by the way when i write gnome-terminal in the vscode terminal say this:

Locale not supported by C library.

Using the fallback ‘C’ locale.

1 Like

No need to reinstall, have you run this command in a terminal and what does it say?

sudo locale-gen       

Usually xterm is part of the base gnome image if this command is unsuccessful from your normal terminal.


yes and said:
Generating locales…
en_US.UTF-8… done
Generation complete.
but still not working even after reboot :sob:

hmm, you might have run into this bug? I’ve never used vscode so can’t help you solve this.

Edit: Found this link to with a possible solution.

Wow! It felt just like magic. I had PyCharm at hand and used its terminal, followed your steps and voilà! Terminal is alive again! Thanks!

I did it but it didn’t work then I have to go to the settings and change the language & format that’s it. It’s working now. It has some issues while installing for the first time.


Thanks, that was what worked for me too.

Had this problem as well and I was seriously thinking of restoring an old timeshift backup but then I found the solution provided by @Hanzel and now I can use the terminal again. Won’t have to worry should this happen again. Thanks.

manjaro-settings-manager → locale settings → add → insert language and Territory

this help you to fix your terminal

1 Like

Thanks, that was what worked for me :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.